Problem with gumball and sphere

Hi all,

We’ve encountered this morning several instances of the gumball not working for spheres giving: Unable to transform 1 object.

Attached is a file with a sphere. I’m not sure how this situation is created. Any thoughts on how to solve this?
Regards,

Arend van Waart

bug_gumball2.3dm (297.0 KB)

Arend: no attachment found on your post. Try the “cloud with arrow” icon to upload a file.

Check, sorry, missed the error message that the file was too big. Fixed it.

Hi Arend- the sphere is a bad object… how was it made? Was it scaled up from a smaller sphere?

thanks,

-Pascal

What kind of things can be scaled up with no bugs? I’m learning some these clean processes, clean files things. Such as retracing curves into a pretty clean closed curve after making the mangled up hybred freaks. Also the problem with triangles on trimmed surface edges, etc that come from commands that never had real trim command in them. Only the rhino processing that somehow involves a trim. That problem and dupborders as I go will definitely help. ANyways, I was just wondering about say scaling up curves, and how scaling up curves that would be hard to create again clean might fare as far as bugs/bad objects? I suppose someone could scale up their curves, then go trace with only NEAR osnap on, and get a fairly exact clean version.

hi pascal, the sphere was created with the sphere command from the menu (Solid > Sphere > (First one from the menu, not sure about the name at this point), no crazy stuff happened as far as I know. I’ve encountered this only with spheres several times today during workshops with 2nd year architecture students. Perhaps it was scaled a bit, (factor 10 max?)

That is odd- if you can turn on CheckNewObjects for a while, while working as you have been, you will be warned when this kind of thing turns up- it would be good to know what causes it- I see that the sphere is located quite far from the origin, that may have something to do with it.

-Pascal

This problem has returned in Rhino 6. See attached file please. Has something to do with the origin, but on my test file, the distances are not outrageous, unless I misunderstand Rhino’s limitations.

TestSphere.3dm (364.8 KB)

Hello - yes, the sphere is a bad object. It has a radius of 2087622.070 - how was it made, was it scaled from a smaller object?

-Pascal

No, it was created brand new. I guess it’s simply too large then?

Hello -
It should not be- and, a new sphere here at that size is OK. (but that is pretty large - why?)

-Pascal

I was working at the wrong scale, but regardless, it would happily scale the file at the origin but not at the point where it was in the model.

Hi Nico - yes, and that is why Pascal asked you how it was made. Can you reproduce this in a new file?

No, even when working at a very large scale it’s fine in a new file. See attached. test2.3dm (2.2 MB)

Hi all

This problem has re-emerged again on a separate file I’m working on, this time at a much smaller scale. Very strange. test 3.3dm (577.0 KB)

Hi all, I was having problems using the gumball on a sphere created from native sphere command. It had a radius of 2996.78, some arbitrary size I arrived at through modelling in place. I created a new sphere at radious 3000 and everything worked fine.