Print problem/bug rhino8

Hello all,

I don’t know if this has been mentioned before but everytime I try printing in Rhino8 I get this “Server busy” alert, which I never had in Rhino 7. But after couple of minutes, it works just fine, don’t get this error again in that Rhino8 window. But if I start another Rhino session, I get this again

Another thing I noticed, in print preview menu, if I want to make a window / set seletion, I can’t change Osnap settings, so I close the print menu, adjust the osnap accordingly and start over again. I believe this was not the case in previous versions in Rhino8.

Thanks !

Rhino 8 SR6 2024-3-26 (Rhino 8, 8.6.24086.11001, Git hash:master @ 8e3b686f596bb6443e56e6dbecf0f54f4888713a)
License type: Not For Resale Lab, build 2024-03-26
License details: Cloud Zoo

Windows 11 (10.0.22631 SR0.0) or greater (Physical RAM: 32GB)
.NET 7.0.7

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics (Intel) Memory: 128MB, Driver date: 2-21-2024 (M-D-Y).
> Integrated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce RTX 3060 Laptop GPU (NVidia) Memory: 6GB, Driver date: 2-15-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 551.61
> Integrated accelerated graphics device with 4 adapter port(s)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 2x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 2-15-2024
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins that do not ship with Rhino
C:\ProgramData\McNeel\Rhinoceros\7.0\Plug-ins\Datasmith Rhino Exporter (d1fdc795-b334-4933-b680-088119cdc6bb)\DatasmithRhino7.rhp “Datasmith Exporter”
C:\Program Files\Bongo 3.0 (64-bit)\BongoEtoUI.rhp “BongoEtoUI”
C:\Program Files\Bongo 3.0 (64-bit)\Rhino6\Bongo.30.rhp “Bongo 3.0”
C:\Users\gubar\AppData\Roaming\McNeel\Rhinoceros\7.0\Plug-ins\D5Conv (e0d5e210-02f6-4ee9-a2b0-1675e225d958)\\Rhino 7\D5Conv.rhp “D5 Sync for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.6.24086.11001
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 8\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.6.24086.11001
C:\Program Files\Rhino 8\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.6.24086.11001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.6.24086.11001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.6.24086.11001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.6.24086.11001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

This problem normally takes some investigation.

  1. Open Rhino and go to Tools > Options > Plugins.
  2. Then at the top of that select Plugins that do not ship with Rhino.
  3. There should be a list like the one above.
  4. Un-check enable for all of them.
  5. Restart Rhino and then Print.
  6. See if the problem happens.

Then if it works, Enable each of the plugins one at a time. Restart Rhino between each one and see if the problem shows up again.

We hope to see if it is a plugin that is slowing down the process causing the error.

That didn’t solve the issue, however after disabling external plugins I felt some improvement, just a bit less waiting time. If nobody else is having this issue, then this might be a problem on my side (windows installation or whatever), I’ll check it on a separate machine maybe and see how it goes.

Just as a reminder, I will be very happy if you can check the print dialogue / osnap thing in future releases ! :blush: 25+ years in Rhino, things got automatic for me, this kind of small hiccups makes me feel old and obsolete :pensive:

Thanks !


Does Rhino give you the same error when you start in Safe Mode? (There is a safe mode shortcut that installs with Rhino).

Yes it gives the same error in safe mode