Plugin for Rhino 5 (32 bit) works on Win 7 but not on Win 10


#1

Hello everyone,

I just installed Rhino 5 and I have to install a plug-in that I need for my work.
The plug-in, which was created a few years ago for Rhino 4 in Win 7, requires two external libraries that have to be located in the same folder of the .rhp file.

I tried to install the plug-in in Rhino 5 (32 bit version) which I run in Win 10 Home and I keep getting the error:
“Unable to load ###.rhp plug-in: could not open file or plug-in failed to start.”

Now, I tried to install Rhino 5 in Win 7 and the same plug-in works just fine. Also, on another computer with Rhino 5 and Win 10 home the plug-in works fine.

I made sure that all the files ( the .rhp and the two .dll) are unlocked (see: https://wiki.mcneel.com/rhino/unblockplugin).

Is there any particular procedure I need to do in order to activate plug-ins in Win 10 on my machine?

Thank you for your help!


(Dale Fugier) #2

Hi @Marco5,

Without the plug-in, we’re probably not going to be very helpful. But perhaps this article might help?

https://wiki.mcneel.com/developer/sdksamples/vcredist

– Dale


#3

Thank you Dale,

that was actually the problem. I was missing the Visual C++ 2008 Redistributable (x86).
Now it works just fine.

Thank again!

Marco