Picture only partially displayed

after entering a digital photo using the picture command, only a small part of the image is visible.
Previous executions of the command ran without problems (about 3 times), but after that the above-mentioned problem appeared. As I use photos for mapping backgrounds, it would be beneficial if there was a solution to the problem.
I have already reduced the size and resolution of the digital photos and converted the working color space to RGB sRGB IE61966-2.1 (before origin embedded display P3, canon CR2 file) according to Photoshop.
Sometimes the color profile was embedded in the output png file, sometimes not. Nevertheless, the same error always appeared, even with different digital photos.
On the first few looks I could not find a suitable topic in the forum.

Thank you & Kind regards

Please run the Rhino SystemInfo command and post the results.
Then we will know more about how you’re setup.

Rhino 7 SR27 2023-2-1 (Rhino 7, 7.27.23032.13002, Git hash:master @ 4a0030c0d354560df03764f4f49ecc5d119e5118)
License type: Kommerziell, Build 2023-02-01
License details: Cloud Zoo

Apple macOS Version 13.2.1 (Build 22D68) (Physical RAM: 16Gb)
Mac Model Identifier: iMac20,1
Language: de-DE (MacOS default)

AMD Radeon Pro 5500 XT OpenGL Engine (OpenGL ver:4.1 ATI-4.9.51)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 8176 MB
Graphics: AMD Radeon Pro 5500 XT
Displays: iMac (217dpi 2x), SyncMaster (305dpi 1x)

Graphics processors
AMD Radeon Pro 5500 XT (8 GB)
iMac (2560 x 1440)

A long shot here…

In Settings (Preferences) > OpenGL, is the GPU Tessellation option checked?
If so, uncheck it.

Any better?

For the last photo (it was in portrait orientation), it helped to rotate it 90 degrees in advance, save it in Preview (OS), and then load it into Rhino. After that it was displayed correctly, but in Rhino needed to be rotate back 90 degrees.

Made it shorter… Thank you…

OpenGL, the GPU Tessellation was and is unchecked…

Another thing to try is to start up Rhino with only 1 monitor attached.
You have enough VRAM for one high resolution screen.

I’ll assume you have tried resampling these images drastically to see if there is a size that displays correctly?

For only one high resolution screen? Sorry my expertise is not in computer hardware or english;)
I´ll try it.

Yes, I tried that already - 0,5x & 0,25x of the original size and 200 ppi instead of 300…

I have a MBP with fairly similar specifications.
Can you post a 3dm file with just the Picture surface in it?


done… no change… but if I rotate the images 90 degrees in preview (OS), save them, then rotate them back 90 degrees in preview and save them again, they load correctly in Rhino…


Sorry but the Rhino file is > 20 MB (56 MB, 2 pictures) - I can´t upload it…
I´ll try to make the pictures even smaller…

at least an impression meanwhile…

indeed… thanks for the information and at least i found a workaround… I think, I´ll be able to send the 3dm file only tomorrow…