Offset - different seam in opposite directions

hello everyone.
i have a doubt about how the offset works. which i have noticed in both grasshopper and Rhino.
If I have a curve and I perform the offset in the 2 directions, in one of the two resulting curves the start-end points change. This creates a problem for subsequent developments - for example to create surfaces between pairs of curves you have to use a shift.
Can anyone explain why and how to make the resulting curves maintain the same seam as the original curve?
Thank you

Translated with (free version)
Thank you (6.0 KB)

Can you run the SystemInfo command and paste the results here? I fixed a similar issue for 8.7 here. Your Grasshopper definition also doesn’t have the curves internalized.

Your curve is not internalized and there is no Offset Curve component.


Hello mr. Joseph.

Yes, i did the offset in Rhino but anyway i noticed you get the same results bot in Rhino and gh. I’ll do in 2 minutes.

Your file is useless :bangbang:

here’s the file! sorry, I forgot to save after internalising… :sweat_smile: (9.5 KB)

Hello mr,Joshua
here the results of SystemInfo

Rhino 8 SR6 2024-4-10 (Rhino 8, 8.6.24101.05001, Git hash:master @ 32c244aa711e0034e75bec2e87d093c764820b96)
License type: Valutazione, build 2024-04-10
License details: Cloud Zoo
Expires on: 2024-07-29

Windows 11 (10.0.22631 SR0.0) or greater (Physical RAM: 16GB)
.NET 7.0.0

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics (Intel) Memory: 1GB, Driver date: 3-16-2023 (M-D-Y).
> Integrated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce RTX 4060 Laptop GPU (NVidia) Memory: 8GB, Driver date: 10-18-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 537.70
> Integrated accelerated graphics device with 4 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-18-2023
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8188 MB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\SolidTools.rhp “StrumentiSolidi”
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 8\Plug-ins\RhinoLabsTools.rhp “Labs Tools di Rhino”
C:\Program Files\Rhino 8\Plug-ins\IdleProcessor.rhp “ProcessoreInattivo”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rendering di Rhino” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\import_ACAD.rhp “AutoCAD file import: import_ACAD”
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”
C:\Program Files\Rhino 8\Plug-ins\MPlane.rhp “PianoM”

I opened the file you sent
it gave me this result

So no problem in R7 and R8… :roll_eyes:

1 Like

ok fine! same script, different result…so it must be an issue of rhino or gh… i have no this same result :thinking:
lets see what @Joshua_Kennedy say.

He already told you it’s been fixed. You need to update. I’m using Rhino 8 SR7 2024-4-10 (Rhino 8, 8.7.24101.10001).

Ah, that’s OK, I didn’t realise. I will update, thank you both @Joshua_Kennedy.
Have a good one.