Offset Curve on Surface - Rounded edges when offset outside

Hello experts, I have problem getting the outside offset corner sharp, Is there any way please to fix it?

Thank you,

In the command line click on Corner=Sharp

1 Like

That is the dialog for Offset. The title of the post suggests that Nada is using OffsetCrvOnSrf which does not have an option for sharp corners. A post from six days ago about the same issue which includes a work-around to obtain a sharp corner:

Sharp corners should be an option with OffsetCrvOnSrf Someone from McNeel will need to agree and put it on the heap of requests.

You are right, I misread the title, sorry for the confusion.

1 Like

Thank you Phos4 for your reply, I do have these options in Offset command but not in OffsetCrvOnSrf!!
Could be bug?

Thank you David, so is there a way to fix it or not? Appreciate your help!

@Nada The thread I linked describes a method to obtain sharp corners. Did you look at it?

It does not appear possible to have OffsetCrvOnSrf produce sharp corners directly.

Thank you David! Yes I read it but I was a bit confused, sorry my mistake but it is clear now :+1:

Hi Nada -
I have added your vote to the open feature request - RH-23754.

Thank you Wim!