No compute.geometry in Services

I’ve installed rhino compute successfully on an AWS EC2 Windows 2019 server.

I do not see compute.geometry in the list of Services. All works well if I run compute.geometry.exe explicitly.

As I understand it, if compute.geometry is a service, as advertised in the install instructions, it would automatically start when the instance is restarted.

Is there a way I can manually create the service now that everything is installed?

Bill

@AndyPayne has put together this guide for installing compute on AWS. We recommend following this guide first: How to create a virtual machine (VM) on Amazon Web Service with C#, VB

I would recommend following the guide that Luis refers to. Running compute.geometry as a service is no longer necessary if you use this new technique for running compute on a server

@BillO To follow up, if you’ve already setup your AWS EC2 instance, then you can probably proceed with this setup:Deployment to a Virtual Machine running IIS with C#, VB. We’re now recommending that rhino.compute gets installed behind IIS. When IIS receives an incoming message, it will handle launching rhino.compute and the child processes. Let us know if you have any questions or if something in the guide is unclear. Thanks.

1 Like

I did all of that and then followed the install instructions on GitHub

Yikes! Looks elegant, but 70 steps? Is there any chance this will be a script(s) at some point?

Thanks @BillO. Yes, we’re looking at further ways we can simplify the process. For sure the section on publishing rhino.compute can be simplified to a script, or just a download that gets unzipped/installed on the VM. But, we’ll continue to optimize where we can.