Newbie question about extruding

Hi all, I have a newbie question as I cannot imagine this is not possible in such a great peace of Software as Rhino. I am using Rhino v5.
So I have a solid and I want to extrude some faces from it (see image 1), but I don’t want to extrude them each, since it is going to take too much time later on (image is just a mock). I tried to select them all and extrude them, but when I set the direction, they all go in that direction (obviously) and I want them to go “in all directions in that way” - so in direction of their normals (see image 2) and for the exact same distance.

I bet there is a really simple trick to this, for example in maya you have the option “keep faces together” when extruding faces of a solid. I am looking for a command that does pretty much the same if possible. Thanks for your attention!

Image 1

Image 2

Hi Blaz - OffsetSrf is the closest thing that comes to mind, if I understand you.

-Pascal

Hi pascal, thanks so much for quickly looking into my problem!

OffsetSrf does the job for one part, but the rest is still a little bit of a problem. Maybe I was a bit unclear, yeah. So the problem is, what I wanted to say, that I can not get the offsets to be kept together - as with for example Maya command “keep faces together”:

In my case what I want, is to have it like I drew (red dots):

Is there a way to do this in one “move”? I know I can now just move one face to another, but I would rather see if there is a trick to do that :smile:

Hi Blaz - If you join the surfaces before offsetting,they will stay together. Does that do it? (i.e. it sounds like you want to offset, say a box, to be a bigger box, not six shallow boxes sticking out from the original faces.

-Pascal

Some graphics here.

  1. Delete the small rectangles after extracting them with _ExtractSrf:

  1. Connect surfaces, and join them:

  1. Offset (pay attention so options):

Thanks a lot guys, I was wrong with the workflow how I wanted to achieve a certain result, but with your help I got now and it is giving me the results I want to have. Thanks so much!

Just a side question: are there known bugs with first a 0.05m extrudecrv and then offsetsrf from that extrusion for 0.05m, (“outside”, straight corner), since I am getting some strange geometry only with this “settings”, everything else is working fine…

You might want to show a snapshot of geometry you get. Also pay attention to internal faces. Trim them off to get a solid.

Hi Blaz- if the file tolerance is .01, that is too close to your distances- try setting the tolerance to .001 (DocumentProperties > Units page)

-Pascal

Yes, that was the problem! Now it’s working, I don’t know how I didn’t think of that yesterday…
Thanks so much for all your support!