My y-axis label has disappeared!


(Menno Deij - van Rijswijk) #1

For some reason, I think since the SR4 upgrade I had recently, my Y-axis label has disappeared in all viewports. Any idea how to re-enable it?

Thanks!

xyz_noY.jpg


(John Brock) #2

That’s odd. I don’t think there is any U/I exposed to control that.
Try messing with your Grid option in your current display mode just to see if you can effect a change.


(Menno Deij - van Rijswijk) #3

Ok, I’ve tried this, but that has no effect. This got me thinking though, and I went to View -> OpenGL and switched off "Use accelerated hardware modes"
This gives me back my three axes labels! Switching it on, though, removes either the X-axis or Y-axis label again. Restarting with this option off and re-enabling it does not work either.
Next is to update my NVidia drivers I guess. Is there anything in the details panel (see picture) that jumps out to you where the problem may be?


(Menno Deij - van Rijswijk) #4

Unfortunately, updating to the latest NVidia driver does not solve the problem. Any ideas?


(Menno Deij - van Rijswijk) #5

Ok, now it gets really weird :wink:

I saw the BBox Display option in the Display panel and thought, “hey, I wonder what that does”? Switched it on, saw the functionality and switched it off.
Guess what? My Y-axis label is back after toggling the “BBox Display”. This only works if between on-toggle and off-toggle the viewports gets a redraw through, e.g., a small panning. Unfortunately, when I restart Rhino, the label has disappeared again.


(Brian Gillespie) #6

@jeff, any ideas?


(Jeff Lasor) #7

None at the moment… The only time I’ve seen this is if/when Rhino issues an OpenGL directive that is not supported by the driver…However, in those cases ALL labels disappeared not just a specific one.

Is this happening in all viewports? Using ANY display mode?

Have you tweaked any setting(s) in the display mode(s)?

-J


(Menno Deij - van Rijswijk) #8

Thanks @jeff, your comment put me in the right direction. I indeed had some custom settings in some of the display modes. I gave all of the display modes a “Restore Defaults” and presto, my axis labels are back. Thank you all for your ideas :smile:


(Jeff Lasor) #9

That’s great, glad to hear things are working again… However, it would be good to see if we (you) can narrow down exactly which setting was causing this…unfortunately it sounds like you’ve already nuked things back to their defaults.

So, in the future, if this happens again please export your display mode that’s causing this issue before you reset to the defaults…send me the resulting .ini display mode file and I’ll be able to see which settings you’ve changed…and hopefully have an idea why your card is having an issue with that particular setting.

Thanks,
-Jeff