Minimum Leader Length


#1

@lowell You seem to be the dimension programming guru, does the explanation of this problem make sense to you? I was discussing this with pascal in another thread, but it got kind of fuzzy.

imageOrdinate Dimension.3dm (77.3 KB)

It becomes extremely difficult to keep the dimensions on the page because of the minimum length of the leader.


(Lowell Walmsley) #2

@donl517 -
After you pick the point for where you’re dimensioning, look at the command line and set KinkOffset to something like 0.01 then pick a point for the end of the dimension.
That will stick for the session, but not between sessions. I’m not really sure how that should work.
It looks like it starts out way too big. I don’t remember just how that gets set, but I’ll see what I can do about it. Maybe starting with your extension offset would work.
Any other suggestions are welcome.

https://mcneel.myjetbrains.com/youtrack/issue/RH-45866


#3

Ah Ha! Thank You!!! That has been driving us nuts!

There is nothing in the documentation, about this setting, anywhere I can find. I never thought about it being in the command line.

The help file says: “A kink is a point where a curve dramatically changes direction.”
Since we are not changing directions, why is there a kink?

Would it be better to have this in the settings page, instead of the command line? (at least then we could save our preference across sessions)

Thanks,
Don


#4

Lowell,

I thought about this some more driving into the shop.

IMO if I have to change a setting every time I open a software application, that setting should be persistent.

My $0.02

Thanks,
Don


(Lowell Walmsley) #5

I agree about that.
I was just telling you what you could do for now until I change something.
It could have been part of a dimstyle, but that’s pretty hard to change at this stage.
I’ll change it to start out pretty small and save it between sessions.
If that works for you, great. If not we can revisit it


#6

@lowell your idea of using one of the existing settings as a starting point, is probably the best solution, for an initial value.

I will let you know how it works for us.

Thanks,
Don


(Brian Gillespie) #7

RH-45866 is fixed in the latest Service Release Candidate


(Kelvin Cheng) #8

@donl517, I added the option to the help topic, thanks.

http://docs.mcneel.com/rhino/6/help/en-us/index.htm#commands/dimordinate.htm

(1) and (2) are the kinks.
image

The initial value of KinkOffset was 1 before the fix. The fix changed it to 0.1. It does not depend on another setting.

Thanks,
Kelvin