Lands design installation error

Hi there,

I’m trying to install Lands on win 10, but the installtion do not recognize my Rhino 7 (7.14)

Does anyone know what to do about this?



Hi Thomas,
Just install the most recent Rhino 7 update (Rhino - Download - Rhino 7 for Windows). Then reinstall Lands Design. Make sure there is no Rhino session running in that moment.
Let me know if the problem persists after that.

Hi Francesc,

Thank you for your reply,

I’ve just installed the 7.16 and did a new try, (and without rhino open.)
But it did not work unfortunately :frowning:
And just downloaded the latest version of lands.

But I still get the same message.
I can’t choose “install as admin”, as i’m not the admin (the IT department is). Could this be a problem?

Or do you have any other suggestions?

Oh wait. apparently I have the administrator rights :slight_smile: Just looked it up

But it still does not work

Lands looks for the InstallPath value in the following Windows registry key:

Since you say you don’t have admin rights, and you say you have just installed Rhino 7.16, I wonder if you have installed Rhino 7 in a per-user basis, and it has been registered under the current user (HKEY_CURRENT_USER) and not for the whole machine (HKEY_LOCAL_MACHINE).

You can (carefully) explore the Windows registry by typing “regedit” in the Windos task bar search box.

Hi Albert,

Thank you for your reply!

Just checked, but I think its installed in the right directory, right?


The HKEY_CURRENT_USER, looks like this:

Ok, looks fine.
And what’s the value of InstallPath? Does the directory exist in your hard drive?
(it’s usually C:\Program Files\Rhino 7)

I think that one is right as well:


Ok, the directory exists. Sorry to insist but, is this the path stored in the InstallPath registry value? (I can’t see the values in your screenshot)

Ahh, sorry. I didn’t get that :slight_smile: But yeah It looks right too… :roll_eyes:


It’s strange, that should work… Let me test the installer with Rhino 7.14 or newer.
Meanwhile, have you tried to uninstall Lands first? (in the case you are updating it)

Yeah, that is strange! :frowning:

Lands is not installed yet, so I can’t uninstall this one.

Thank you for testing! :crossed_fingers:

One more question, do you have Rhino 6 installed? If so, what version?

No, I only have rhino 7 installed

And now some random theories :slight_smile:

Should the installer of lands be in a specific location? (right now its in downloads)

Could there be any left over install files, from the first try of installing lands, where rhino wasn’t updated?
(have no idea where to find these and delete them, though)

No, no, the msi locations doesn’t matter. And no files can remain from a failed installation.

I’m low on ideas, since the installer should work on your current setup. I can only imagine Windows exposing to the installer a different registry image in respect to what you get with regedit.

To ensure we run the installer with full admin rights, try the following:

  1. with the SHIFT key pressed, right-click on the Lands installer file. In the context menu select “Copy as path” (or something like that). The file path will be copied into the clipboard.

  2. in the Windows task bar search box type “cmd”, and right-click on the “System symbol” search result. In the context menu select “Run as administrator”. A black command window will appear.

  3. In the command line, type:
    msiexec /i
    type a space after the “i” character and then right-click on the black background. In the context menu select “Paste”. The file path of the Lands installer will be added to the command line.

  4. Press enter. The Lands installer will be launched with administrator rights.

This ensures that the msiexec application (the one that opens msi files) runs as administrator.

Does this make any difference?

1 Like

You’re a genius!!!
Now it works :slight_smile:

So apparently I was not installing as an admin, but I did have the rights, just couldn’t use them by right clicking…:slight_smile:

Thank you so much for your fast help!