It's about mesh edges

could you anyone solve this problem?!

I can’t get outside of lines from this model. I tried several models but only this can’t be done…
sorry for this such a basic question

model (10.4 KB)

What do you mean?

Your mesh doesn’t have naked edges because is closed.
The component you are using, “Weave Back”, is still experimental (so it says on my installation).
It is making a big face for the whole shape:

(I’ve manually detached and moved the face)

Maybe you could removing that face by sorting by area and picking the largest.

I’m so sorry for my poor explanation…

I mean I wanted to try origami with Kangaroo2 so I set 2 kinds of line, one is for Valley fold and another is for Mountain fold and create a mesh. I delete subsequent code to ask this question but I have it don’t worry !!
anyway it needs outline of mesh from E1 as output of NEdges though, it turned red and said empty. I can’t understand why?

because I tried several models and they are fine with exact same code like above picture.

If you are planning to simulate this as origami, you will need to triangulate it anyway, to prevent the area of the quads changing. This particular design is also only possible to fold because the quads twist, and should be triangulated like the lower middle image Here.
If you generate these diagonals first you can also avoid the issue Riccardo points out above, where an extra large quad is getting added for the boundary, by setting the max side count to 3 in the Weave back component.

Thank you all I did it!!!

as Riccardo told me, there is an extra large mesh and this was disturbing

Actually I dont understand enough soI’ll keep studying

hypar (33.6 KB)