Issues debugging in VS while running GH

Recently, my app started to crash if while running a debug session on my rhino plugin, I execute grasshopper. This didn’t always happen. Now I am working on interop between GH and my plugin(its a rhino plug, not a gh plug). I need to be able to run GH while debugging.

Managed Debugging Assistant ‘FatalExecutionEngineError’ has detected a problem in ‘C:\Program Files\Rhinoceros 5.0\System\Rhino4.exe’.

occurs when I launch GH. I have a slight hunch it is realted to some issues in GH. For example, when I run GH, I get a bunch of errors about duplicate guids and such. When I am not debugging I can just click replace and move on(GH then runs fine). But when debugging, the app goes into break and then exits when I click continue.

Is there another possible cause or should I just “fix” my gh?

update…yes, fixing the load errors in GH fixes this issue…

This sounds like you may have copied GUIDs from some place that are already used by existing plugins. For your own plugin code you should always generate new GUIDs. Is this how you fixed your trouble?


I think I had multiple versions of other peoples plugins in my gh folder. Deleting the ones that through the warnings fixed it.