Issue Energy plus components Ladybug 1.6 and Rhino i Revit 1.5

Hello all, this bug has been happening for a while apparently but it still hasn’t been resolved in Rhino Inside Revit 1.15.8522.
None of the energy plus components can be used with Revit at the monent. I know about the set_python_path.bat that could fix the problem but it didn’t help me. I tried to reinstall Ladybug 1.6 from Revit directly but also no luck there.

  1. Solution exception:
    Failed to import ladybug:
    No module named _sqlite3

Thomas, Ladybug has there own discourse forum for their plugin. This doesn’t appear related to Rhino.Inside.Revit.

I suppose, but it only happens when in the Rhino Inside Revit environment, totally fine in Rhino 7, I thought you might have some insight.

The only think i can gather is that _sqlite3 isn’t being loaded, which could be a conflict with other Revit Add-in, when the addins load the first to load wins. Is there a pollination revit plugin loading as well?

Rhino.Inside.Revit doesn’t load _sqlite3.

1 Like

No I don’t have any of the pollination plugins, here’s my list of plugins

I will try on Revit 2023 with no plugins loaded, see if there’s a difference

Okay, even worse in 2023, none of the ladybug components load properly.

Excerpt of bug :“1. Solution exception:
Failed to import lbt_recipes:
No module named lbt_recipes.recipe”

Or “1. Solution exception:
Failed to import ladybug_rhino:
No module named ladybug_rhino.grasshopper”

This was done with almost no plugins loaded apart from Rhino Inside Revit

I did the basic installer

placed a few components, it appears they do not find any of their python modules.

Perhaps ask on their forum if they can support working in the Rhino.inside environment?

It works in 2022 but not in 2023. I will definitely post on their forums but that 2022 2023 difference is still peculiar, have you tried the same thing in 2022 ?

I’m guessing its python environment variables (script paths). My test was in 2022.1

By uninstalling and reinstalling Ladybug directly from the interface of Rhino Inside Revit, its seems to come back to normal, across 2022 and 2023, apart from the Energy Plus components, so close.
I get no traction on the ladybug forums Issue with Energy plus components in Ladybug and Rhino inside Revit 1.6 - ladybug-tools - Ladybug Tools | Forum


Thanks for trying to answer this, @Japhy . Ladybug Tools has full support for the Rhino Inside environment but you have to set it up correctly and avoid the conflicts between the version of IronPython that Revit uses and the one that Rhino uses.

The reason why you get all of the components turning red has to do with the fact that Rhino has structured the Inside ecosystem such that each and every “Inside” environment has it’s own IronPython search paths. So, whenever you start using a new environment, you need to re-run the set_python_path.bat as I note here:

For the issue with the sqlite3 module, I’m nearly positive that this has to do with the Revit IronPython interfering with the Rhino IronPython. Hopefully, someone else on the McNeel team could shine some light here but I know that there have been many cases in the past where Autodesk’s IronPython conflicts with Rhino and a quick search will reveal this:


Interesting, so anything that uses Ironpython is basically blocked from accessing anything

Worked for me. Thanks.

1 Like

Hello, I had the exact same Issue with Rhino Inside Revit not finding _sqlite3.
I’ve found an additional solution that did work for my by uninstalling a Revit plugin/add-on that was also working with Python and Ironpython, see my post here: