Isotrim Surface

unhandled

#1

Hello,

I have a surface patch obtained from a scan. I was trying to apply the isotrim feature and it seems to be working on the untrimmed surface rather than the trimmed. Is there a way to get around this? I have attached the surface file in .igs format.

Shell_1_new.igs (175.9 KB)

Thank You


#2

This could be one way…

Shell 1 new_re.gh (107.2 KB)


#3

I had a look and even though it works it produces several patches and I was trying to merge them but didn’t seem to work as edges are far apart.

For_Shell.gh (23.4 KB)
Shell_1_new.igs (175.9 KB)

I am using the above code to generate this.

I have used the .igs surface to make the above but when I morph it onto the surface the alignment just goes off.

I then tried the isotrim and it didn’t work either. I am trying morph what I have on the planar surface to the original. Is there a way. I am not sure if I am making self clear but really let me know.

Thank You


#4

Looks like you didn’t even use the definition I provided… and asking to me again? and I don’t understand your discription at all…

Shell 1 new_reV2.gh (106.1 KB)


#5

Hey, I tried you definition and the region intersect is not working, it says “Object reference not set”.Why is that happening?

And let me try and explain.

I was saying that I require a smaller surface (highlighted in green) from the original surface that’s why I was trying isotrim. I want to achieve something like this

I want to create a similar pattern on both surfaces so that they fit together. something like below.

As you have shown your method will definitely work but I am having trouble with creating a sub surface off the original one. I hope this is a bit clear? Please let me know, thank you so much.


#6

OK. Check this as well. and remember you’ll only know what you are going to do without detailed explanation.
Clipper plugin is required.


Shell 1 new_reV3.gh (63.2 KB)


#7

This is just amazing, thank you so much. You just saved me so much time. Thank You


#8

Hello,

I am sorry but just having trouble sorting out the same surface with a hole. I am following your code and still understanding it. but cannot seem to get the same result for the hole. Probably the math.

Just like before but with the attached surface. Shell with hole.igs (225.7 KB)

Please let me know, Thank You so much


#9

BTW this is the original surface as mentioned in the above question, Original_Srf.igs (3.4 MB)
Really nothing from my side, I tried it all day and was not able to.


#10

Hey, @Gaurav_Chauhan.
I’ve already gave you everything you need and It’s only a matter of a slightly different application.
And since this is not very parametric, you don’t have to do this using GH. You’ll get a much faster result with FlowAlongSrfcommand in Rhino.

Shell 1 new_reV4.gh (117.1 KB)


#11

Hey,

I didn’t write you earlier, yeah I was able to achieve the above but am facing this new issue. Try your code with the two surfaces I have attached. The brep edges mess up. I can go in and manually fix it but can this be prevented? and why does this happen?

I ran my code to get the above and also yours and I got back the same result.

Patch_2.igs (1.0 MB)
Final_Patch_1.igs (1.2 MB)