I can`t connect Rhino and Python(Atom)....Please help!

Can you try deleting this file:

/Users/janlibera/Library/Application Support/McNeel/Rhinoceros/MacPlugIns/IronPython/settings/version.txt

and then restarting Rhino?


I have exactly the same problem. Autocomplete does not work and Listener brings up the error message
Tried with latest WIP. no difference



I deleted version.txt but still not working.

I knew deleting the file wouldn’t work after I read that Detlef is having the same problem with WIP. Still investigating. Thanks.

@jllibera, @detlef_mueller,

This is a long shot but are you running the Cisco AnyConnect VPN client by any chance?

If so, can you uninstall it and then reinstall it without installing “Web Security”?


I’m not using it. But your suggestion inspired me to try something else. I turned off ESET security pro which I’m using and killed all other background processes which were related with ESET and it WORKED!
Now I have to figure out how to keep ESET working without distracting communication between Atom and Rhino.
Thank you very much for your effort and help!
All the best


ESET is probably doing the same thing as the Cisco VPN client which is blocking the http request because it sees it as a cross domain request, i.e., the page that has the request asking Rhino for completion data is not coming from Rhino (Atom is based on chromium and node.js) therefore it’s flagged as a security risk (it’s not because the source is your file system). It seems that the Cisco VPN client only blocks requests over ports 80 and 8080 (and we’re unfortunately using 8080). I’ll make (sooner than later) the port number that Rhino is listening on configurable. Hopefully ESET only blocks specific ports.

What a relief! But unfortunately code completion still not working.

:frowning: Is it the same ERR_EMPTY_RESPONSE as above?

No. Something like that:
I also tried to make a rule for 8080 port but it didn’t work.

Can you try this?

In Atom can you type shift + cmd + P

followed by the view installed packages command

then in the Installed Packages search box type metrics

disable the “metrics” package.

Let me know how that works out.

This is with ESET completely disabled right?


Above when you said it worked you meant that the “Save and Run in Rhino” Atom command works right?

Yes, the script worked. Just code completion still not working.

It’s hard to figure this out since I can’t duplicate the problem. Next time I work on this I’ll make the port configurable and that should help. I’ll also keep investigating. If you’re willing to do some tests when I come up with something I’ll contact you offline.
Sorry this is not working for you right now.

Hi Alain,

we have Cisco VPN installed on all our MACs. Its not possible to reinstall it, because this is setup by our IT Department and they do not reconfigure it. When can we expect to have the port configurable? We plan to work on bigger developments and would appreciate to use it.

thanks, Detlef

Hi Detlef,
I can’t put an exact time on it but it will be very soon because it’s the first thing I’ll do when I get back to this project.

Hi Everyone
I have the same problem and I can’t connect my rhino to Atom…
I followed up all posts but finally unsuccessful.
could you please help me?
my rhino version is 5.3.2