How Do I Actually Download Rhino WIP?

I’m in the Serengeti group, but when I click on the “Download Rhino WIP…” link I go to what looks like the standard Rhino download page (see image), if this the correct page, what link do I click on to download Serengeti?


I have the same problem.

Same here

This should be it:

Edit follow the link below amd click on red text
"Read change log"

Enjoy and report your findings.


Willem, thanks for responding with the link. However when I click that I still end up at what seems to be the normal Rhino download page (unless it’s a sneaky disguise?), and I’m still confused as to what I should be downloading?? Please see the attached for what I see…


You need to click on the link provided at

Only people coming from this page will have access.

@steve Doesn’t work for me… No link on that page that I found. --Mitch

@brian I’m going to need your help here. I’m not sure what is going wrong.

I confirm. The workaround don’t work.
The last page il always the standard downllad page.

Thanks Willem, but it doesn’t work.
Getting the standard download page.

Thanks Mario, but this one doesn’t working either.
What I noticed with the Serengeti signs is that they all have a padlock in them so maybe they all are still blocked.

Thanks Steve, this link worked for me. :grinning:

It works now

Still can’t get the download to work, from any of the links above or main Serengeti intro post.
Always end up in the general download page.
Any ideas how to get the latest WIP? I let mine expire accidentally…



Hi Jarek - not working here either - hang on a bit…

@Jarek if you go from the link in Bob’s Serengeti welcome message, does that work?


@pascal, nope, not from the Bob’s welcome page either (general download page shows up)

Hi Jarek - just a shot in the dark but perhaps clearing the browser cache might do it? If not, I’ll see if I can enlist a bigger brain to have a look.


That did it; going to the link with browser history cleared made it work. Thanks Pascal !


The changes link that other people have posted is not correct. Use this one:

@brian This behavior from the Welcome page is back. Brian’s Oct 15 link also produces the normal download page. Wassup?