Hops not working?

I don’t think it’s as simple as that. I just tried @maje90’s code again and after resetting the Hops path, I only had to reconnect his ‘Curves’ param to trigger a successful response. Don’t know how I missed that earlier. I asked earlier but don’t know if it works differently with “Referenced Circular Curve” vs. internalized geometry?

Which version of hops you have?

How would I know that. My R7 is up to date.

Version 7 SR26
(7.26.23009.7001, 2023-01-09)
Commercial

These are the files of yours that I’m using:

hops test.gh (2.7 KB)
hops test 2.gh (12.2 KB)

Hops are not integrated with Rhino/Grasshopper, it’s a plugin.
Check PackageManager.

Here it is.
I guess each version have its own bugs/perks.
It’s probably better (bug-reporting-wise) if you use the latest one.
You can always revert back to older version.

It should work with inputs=whatever but outputs=only group+name method. I didn’t manage to make it work with contextual bake, if input is a simple list.


Uh, yeah, once this is fixed, Hops should totally be shipped with rhino!

I personally don’t use hops, only a bit of player, as I work almost alone with GH.
But, I make GH courses here and then, and working teams really find useful to have shared GH functions to use as rhino buttons or hops.
Last lesson (yesterday), I were like: “… and then, after grasshopperplayer, see this neat thing: Hops!” … and it didn’t work! :joy: But at least next lesson I will show them the named group method…

1 Like

Very interesting. I can see now that my version is old but had no clue. Trust me, I’m not the only one who doesn’t follow all these details. But if I install the latest, Hops won’t work so why bother? Thanks for the warning. You’re on the bleeding edge. :laughing:

Hello @maje90 Were you able to get your Hops components working with Tree Access set to false? I believe I have the same issue; see my thread from a couple of days ago, and this post by another user from much earlier.

The second post mentions this bug being introduced upon updating Hops to 0.15.0, so I’m in the process of trying some of the earlier versions now. So far, 0.14.1 still has the bug.

Edit: I can confirm that this bug is not in 0.13.1. So perhaps reverting to this version is an option if you have no need for Tree Access (introduced in 0.14) and Internalize Definition (introduced in 0.15).

2 Likes

I don’t think the bug is related to Context Bake. The old group naming method did not fix the errors described by @maje90 in the first post, at least based on my testing. It seems to be related to the Tree Access implementation instead, as the bug is present from 0.14.0 onwards.

2 Likes

Yep, this doesn’t work too:
2023-02-12 21_06_03-Window
test hops 3a.gh (2.8 KB)
2023-02-12 21_04_51-Window
test hops 3b.gh (5.9 KB)

@Joseph_Oster @maje90 @hkit.yong I have found the bug that was causing this issue. I hope to make a new release which fixes this shortly.

3 Likes

@Joseph_Oster @maje90 @hkit.yong I’ve just published a new build of Hops (0.15.5) which should fix the issue you were seeing before where it would ask you to supply at least one item. Can you please test on your end and let us know if this resolves the problem. Also, does this also fix the Context Bake issue? I didn’t change anything in the code for that component, but in my testing this seems to still be working as expected. I’d just like to know if I can close that other YT item, or if I need to do some more digging.

3 Likes

It’s working!


At first it wasn’t, because I was testing one of my scripts that output groups.
Apparently, this doesn’t work at all:
2023-02-16 15_42_33-Window
But, this is a different bug, unrelated and somehow one can work around it.


Tested the same function.gh (without groups) with GrasshopperPlayer and Hops, both works now!

“RH_OUT:paramID” format seems to work too, but similarly not with groups and I tried just twice as I consider is superseded by contextual bake…

Thank you!

2 Likes

PS

Seen this long time ago but it never stumbled me: apparently edyting any of:
2023-02-16 15_59_19-Window
won’t trigger the need to save the document.

Moving them on canvas, changing preview/enabled state do trigger it.

But changing prompt message, “at least” “at most” amounts, tree input flag, etc etc, does’t.
You can edit those and close the document without saving without having a warning.

1 Like

Great. I’m glad it’s working again. Also, the groups issue appears to be repeatable on my end as well. I’m pretty sure groups were working a while ago, but I’ll have to dig in a little bit to see why they aren’t being returned. Thanks for reporting this.

Ok. I can probably add that to the list as well.

1 Like

The list access/supply at least one item bug has been fixed on my end as well with the update to 0.15.5. Thank you for your efforts!

1 Like

This has been fixed and should be available in the next public release of Rhino 7 and/or Rhino 8 WIP.

1 Like