Help with locked object is gray


#1

Can’t seem to find the setting for making a locked pictureframe to not be a gray color.


#2

This is display mode controlled. You can go into the display mode, and find “Locked object appearance” and you will have several choices, including not to gray the object out. This is a global setting for all locked objects under that display mode, there is no individual setting for something like a picture frame object.

–Mitch


#3

Thanks for the thorough description. —Mark


#4

Hi Mitch ,I went to display options and then wireframe. then to objects. there are only 2 settings for locked objects. neither setting helped, so I still must be doing wrong.
I looked on older posts to find the answer , but so far none. Thanks,Mark


(Pascal Golay) #5

Hi Mark - maybe look in Options > Appearance >Colors … scroll down a bit. Display modes can control the color but if it’s set to Application settings as in your image, it will look in Appearance > Colors for locked object color. If you change that to ‘Use specified lock color’ you can control it form the display mode… Perfectly clear, wouldn’t you say?

-Pascal


#6

Sorry to be such a dunce about this. What I need is my pictureframe to be locked but not turn any color. I know its me , because it has worked in the past. Just can’t do it now.
So not so clear yet. Thanks,Mark
I did the same thing in the WIP and it locks as needed . Also I compared the settings between the two ( v5 &v6) and they appear to look the same.


#7

If you are having problems setting the display style in a way that suits you, another workaround might be to create a new layer, assign the picutreframe to that layer, then lock the layer.

Sam


#8

Yes Sam that works fine. Thanks for the tip.
Wonder what it means about getting it to work as expected? Any ideas there?
At least it gets things moving forward.


#9

By default, pictureFrames are set to display in the Rendered display mode. So instead of changing the locked object display settings in Wireframe (or whatever mode you are working in), you would need to check that in the Rendered display mode, locked objects are set to use the object’s display attributes. It looks like from your screen grab that your Rendered settings are not at default, so it might be worth a look in there to double check.

Hope that helps,
Sam


#10

Yes, Sam you got it. Set object to application settings ( in rendered mode)and tried it and all is working as expected. Thank you—Mark
Thank you also Mitch and Pascal