Grasshopper2 UI animation

Any way to disable the menu animations? Grasshopper 1 UX is great because its simple and straight forward. All the flashes and pops probably is good for a beginner that needs the extra stimulation, but for us that needs to work on complex graphs, we don’t need the UX to look like some tiktok app.


Which menu animations specifically?

Morning David,

  1. The Hover “swipe” animation over adjacent menus on top
  2. The “blink” animation when nodes are connected

Trying to achieve distraction-free UI, especially on windows 11 nowadays with ads and notifications, etc.

On another note:
Can the ruler marks be added back to number sliders? It gives a visual cue for adjustments despite how arbitrary it may seem.

Thank you

1 Like

I agree. It would be great to have an option to turn #1 and #2 off. In my case, the “swipe” menu unrolling also seems inconsistent - sometimes I get a cascade radiating from the mouse, sometimes the whole menu’s worth of icons appears at once.

(I guess the difference is due to hovering the mouse over the canvas OR clicking on another menu tab, but I’d prefer to avoid a speedbump manifesting because of any of those choices.)


If I could vote, I like to avoid anything in the UI that delays the updating of information.


Rhino 8 SR7 2024-4-25 (Rhino 8, 8.7.24116.03001, Git hash:master @ 651c1fdf6674a7807fb6375caf389630569e584a)
License type: Commercial, build 2024-04-25
License details: Cloud Zoo

Windows 10 (10.0.17134 SR0.0) or greater (Physical RAM: 16GB)
.NET Framework 4.8.4150.0

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: NVIDIA Quadro P2000 with Max-Q Design (NVidia) Memory: 4GB, Driver date: 2-15-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 551.61
> Integrated accelerated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA Quadro P2000 with Max-Q Design (NVidia) Memory: 4GB, Driver date: 2-15-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 551.61
> Integrated accelerated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

Secondary graphics devices.
Intel(R) UHD Graphics P630 (Intel) Memory: 1GB, Driver date: 2-18-2021 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- There are no monitors attached to this device. Laptop lid is probably closed

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 2-15-2024
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
C:\Users\Armen\AppData\Roaming\McNeel\Rhinoceros\packages\8.0\Grasshopper2\2.0.8880-wip.25119\Grasshopper2Plugin.rhp “Grasshopper2” 2.0.8880.25119

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.7.24116.3001
C:\Program Files\Rhino 8\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.7.24116.3001
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.7.24116.3001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.7.24116.3001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.7.24116.3001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.7.24116.3001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

Ah, I misunderstood “menu” in that case. I can absolutely add options to adjust the timing on those, or indeed switch them off entirely. Haven’t really started with settings yet as it is not at all clear which of these things will survive to the beta phase. I thought the tab-panel-hover-preview would be handy, but I get annoyed by it occasionally as well. However it does allow you to more quickly search for a component without the need to click or change the state of the UI. So it’s not a useless animation.

The animation at the start of the ‘preview mode’ begins as soon as the mouse moves over any unselected tab, and it rolls back when the mouse re-enters the currently selected tab or if it leaves the tab area altogether. During this mode the faded preview switches immediately depending on the tab the mouse is currently over.

It actually runs when the current position of the mouse would result in a connection being made if you were to let go here. There’s no animation for the actual connection, because there’s already a visual clue for the connection being made which is the change in wire line style.

But sure, I understand you might not want to see this stuff. Any fluff like this which manages to survive into 2.0-Beta will need to become part of options/settings. And even though there’s no UI for this yet, I have been trying to make sure that it’s all in principle user-configurable.

1 Like