Grasshopper Tutorial_GIS with OSM is not forming the surrounding buildings(Grasshopper/ELK)

ELK (38.3 KB)

Hello, the issue I am having is that Elk is not forming the 3D building extrusion.
I thank you in advance. Stay safe aswell

Here is the ELK code as well as the map osm and hgt.

Hi - there are no files in the Google Drive folder that you linked to…

landscape.3dm (257.7 KB)

My bad about that are you referring to the Rhino file or the other files?

I just looked inside the folder and it should be there

I’m seeing this:

The “map (1).osm” and the “N32W086.hgt” files. Can’t you just zip them and post them here?

1 Like

Also, please note that you are running Rhino 6.1. Please download and install the current 6.23 Service Release.

Generally if Elk doesn’t extrude the building footprints, it’s because there’s no height data for it to extrude to and it does not make assumptions on building height nor does it extrude to a default height when absent. That’s why you are just getting surfaces when you chose the 3d option instead of extruded breps. Currently the ‘height’ tag is the only OSM tag that it reads to extrude on its own, and while I know sometimes there’s a level count for the buildings, i don’t assume an average floor to floor height either so that’s left to the individual to manage.

Just a quick text search shows there’s no height or level tags in your OSM file, so there’s not much for it to go on. You could extrude them by some default amount across the board, or break it out and extrude to different heights based on building type, but that’s still left to you to resolve.

1 Like

Hi - a good example of using all 3 alternatives (height, level, and random) based on the availabel information is in this post: