Grasshopper components look as in wireframe mode

1 Like

What are you asking?


my grasshopper components are in wireframe mode
look at Brep component and the point component

As you can see in the description in your first picture, that brep container is from panda ui. So not the original brep.

1 Like

Those nude components are not family friendly. :slight_smile:

// Rolf

1 Like

Tim already told you - it’s a brep component from a plugin called Panda.


// Rolf

1 Like

Thank you , I’ll remove the panda plugin and see it works

Could you tell me how to roll back to the original Gh_ui ? because I’ve uninstalled panda and the problem still the same

No sorry. May ask at the download site or write the author an email.
Can‘t look at the moment if there are any reset options. Maybe @DavidRutten knows how to deal with it.

You must delete the xml settings files that were modified. Deleting them will restore them to factory default settings. You can find the settings files via the Grasshopper File -> Special Folders menu.

The file which contains information about the component skinning is called grasshopper_gui.xml. If that doesn’t fix everything, you may also have to delete grasshopper_kernel.xml. Be sure that GH isn’t running otherwise it will recreate those files in the old way on shutdown.

unfortunately problem still the same

Those xml files are the only places where these settings are kept between instances of Rhino+Grasshopper. So if deleting those files doesn’t change the way your components look the next time you start Grasshopper again, then something must still be actively overwriting those settings.

I have a question though about one of your original images. Are you saying that the Point parameters look normal and the Brep parameters look weird? All of them?

Maybe post a picture of your components folder. Maybe there‘s still something from panda.

I deleted all panda files from grasshopper library

A long time ago I tried Panda, and if I remember correctly, there was a component or a menu option or somewhere there was the option to enable/disable the hacked panda graphics. Panda comes with an .exe, so to uninstall it correctly you have to uninstall it with its uninstaller or the windows uninstaller. My memory is just as pleasant as those graphics :v

Looks like you have all of food4rhino installed :sweat_smile:

the recent .exe for panda doesn’t show in the windows installer it’s just write it in cmd
and yeah I got all food4rhino installed :joy:

could you run this script and post what’s in there? (10.4 KB)

Delete dragonfly plugin. He changed the design of your nodes.

1 Like