Flow text dots along curve

flow

#1

It would be nice to flow text dots along curves. I have a loft built from cross sections that I’m flowing with a new target and want to bring my marker text dots along for the ride.
Something already out there I’m missing? Or slated for v6?


(Brian James) #2

The only technique I know is to use ConvertDots to make text and then Explode to make curves from that. You could also add PlanarSrf to make surfaces from the curves if that reads better. Then Flow can use these as objects to flow.


(Pascal Golay) #3

Hi Robert - Dots should work, I’ll add this the the heap for V6. For now, I’ll see if a script can help.

https://mcneel.myjetbrains.com/youtrack/issue/RH-36476

@carvecream - See if this quick Python can help for now - use with _RunPythonScript or _-RunPythonScript ("Full path to script file in double quotes")

FlowWithDots.py (2.2 KB)

A fly in the ointment so far is that the Copy=Yes/No turns up twice and the second one, inside the Flow command as I have things now, does not apply to the dots…

@carvecream, @BrianJ - dots are now eligible input for Flow & FlowAlongSrf in V6/WIP… thanks.

-Pascal


#4

Thanks Pascal. Not sure what I’m doing wrong, can’t get the dots to flow. With or without copy.


(Pascal Golay) #5

Hmm - worked here of course…it IS a hack… is it allowing you to select them? Does it end up making points rather than dots on the target curve?

Maybe send me the exact thing you are testing with…

-Pascal


#6

It isn’t allowing me to select the dots. I just have a string of 7 text dots on a curve.


(Pascal Golay) #7

Weird - seems OK here… can you please see if preselecting helps?
How are you running the script? I used both versions of RunPythonScript…
-Pascal


#8

When I preselect, as soon as script is running the text dots deselect.
When I run the script first, I’m able to select the dots, then they deselect.

I’m just using runpythonscript.

Might it have anything to do with my running this on the demo version of Rhino? I’m on new computer at the moment waiting for IT to purchase a couple of new licenses this week.


(Pascal Golay) #9

Hi Rob - eval should not matter… if the script runs at all it should work. I am puzzled - just possible I posted a bogus version somehow - can you toss that one and replace it with:

FlowWithDots.py (2.2 KB)

I just ran that exact script…
-Pascal


#10

super weird. still no go.
dots deselect.
I’m gonna try it on my home machine later tonight.


(Pascal Golay) #11

OK - let me know - sorry for the hassle, I thought I might save you some pain but I’ve caused some instead…

-Pascal


#12

Works on the home machine no problem. Very cool, thank you!
Any ideas what’s keeping it from running properly on work computer?
No pain caused, btw. I always appreciate your efforts and on the fly script making in here!
-Robert


(Pascal Golay) #13

No… not yet. I’ll see if I can make a version that prints out some stuff so we can see, maybe, where it goes South.

-Pascal


#14

Something must be buggy with the instance of Rhino I have open and was testing with here at work last night. I came in this AM and opened new instance and it works fine. Still not working in that other instance I still have open which doesn’t make any sense to me.


(Pascal Golay) #15

Hi Rob - I have, very occasionally, seen Rhino start mis-behaving in different and unpredictable ways after it has been open a long time… for now, unless you can repeat it somehow, I guess I’d … shrug it off and hope for the best.

-Pascal