Exporting to ACAD


#1

Hello,

I draft in rhino, but my firm works with ACAD. I use rhino feet units as a standard. Whenever I export to dwg I have to convert units to inches or scale the vectors by 12 in ACAD to get them to full scale. That’s fine, my problem is that no matter what I do my blocks remain in inches even after I scale the drawing up or change the units before exporting to dwg. What can I do to correct this? What am I doing wrong? I’ve tried exporting in 2004 polylines and default.


#2

Just a thought have you tried changing the units in Rhino before exporting?


#3

definitely


#4

Sorry just re-read your post and you stated that.


#5

it’s fine just hope someone has an answer so I don’t have to learn CAD. I’m not a fan of CAD. It’s clunky and not user friendly, but if I can’t switch between the two seamlessly than I’m going to get into trouble if I keep using rhino. I know I could make the blocks in inch units, but than I’ll get into trouble doing area calcs


#6

Are the block important in the autocad file. Could you explode them in Rhino before export.


#7

that would work, of course, but than it would take too much time to make them into blocks again


#8

multiple people are working on the file whose origin in ACAD. People need to be able to go into the blocks and edit them. The blocks shift and move a lot, so I can’t spend company time converting the exploded blocks into new blocks every day.


(Dale Fugier) #9

@lowell, is this something you can help with?


#10

jherm,
Please explain "…get into trouble doing area calcs."
Getting sq ft calcs from models that are using inch units is not an issue for Rhino. Should be simple matter of changing the units just after starting the area command.


#11

You cannot do an area calc unless you open the block. I would have to scale the block by a factor of 12 before I could do an area calc. It’s just more steps to do and time consuming. It also doesn’t look good on me when other people go into the file and editing it. Regardless, I need a seamless transition between rhino and CAD.

Is there any way to export a rhino file to CAD and keep the units intact. It just seems like a problem with scripting that can be fixed relatively quickly. Am I asking too much? Maybe there is a simple solution like a setting I’m overlooking in CAD or Rhino, or maybe exporting as a dxf or 3ds? I don’t know, but I’ll start testing out more alternatives.

I’m not looking for a work around, so please, if you do not have a solution keep a lid on it. It’s not helpful.


(Lowell Walmsley) #12

When you change from Feet to Inches in Rhino before you export, and Rhino asks about scaling by 12 and you say ok, the objects in the block definitions don’t get scaled but the scale factors of the block instances do get multiplied by 12.
It looks to me like its a mistake to scale the block instances, and instead the objects in the block definition should be scaled.
I’ll write this up to get changed, but I don’t see any good way to do it now without a script to go through and scale all of the objects in your block definitions.

Lowell


#13

Thank you, I appreciate your help