Elefront doesn't bake Substance Material

Hi everyone,

I’m having problems baking geometries with Substance Material using Elefront.
When I input the Substance material into the Define Object Attribute, the baked geometry has a default material assigned, and not the original Substance one (see attached screenshot).

Is there a way to make it work with Elefront Bake component?

I know that this is already working with Human, but I have a large script already set with Elefront workflow, and I can’t switch to Human.

Attached you can find the .3dm and .gh files (it was not possible to internalize the Substance material into the Shader component).

Thank you for your help,


210902_Elefront-Substance.3dm (5.4 MB)
210902_Elefront-Substance.gh (10.3 KB)

Hopefully someone else weighs in here, but maybe you could do the material via layer assignment (and update it via human- separate from the baking logic)

Elefront has its own logic to capture materials, which may not support Substance materials.

I believe Substance materials was an add in Rhino 7, so I can take a look to see if this needs special attention in the next version of EleFront.

Has this problem been solved? Could you include an example using Human and Substance materials?
Thank you!

We’re still working on adding materials to the beta version of the eleFront update. For the Legacy version, the Define Attributes component will also take in a text / string with the name of the Material. With some quick testing, it seems like it still may not grab all material types, but you may give that a go - define the material in Rhino, and just pass the name of it into the Define Attributes component.

If it still doesn’t work, it’s because Substance materials are being stored somewhere that old eleFront doesn’t know about.

We’re working on it!

No problem, I’ll manage to do it. Thanks for your great work, elefront is amazing.