Duplicate ID error when loading new package version

im currently running into big trouble trying to deploy a new version of my CS and VB Rhino Package.
No matter if I change the version and or the GUID in the (CS) AssemblyFile, every time I try to upgrade from the 1.0.0 to the 1.0.1 package in the package manager, Rhino throws the “ID already in use” error message.
I have already confirmed that the changes are actually applied to the rhp by inspecting the file, viewing it’s properties in the Rhino Tools → Plug-ins tab and via registry.
I can install the new version of the package, but I have to manually remove the old registry entry before doing so.
Our yak file consists of a PluginCS.rhp ,a PLUGINVB.rhp and a manifest file. The CSharp file always causes the error.
One thing I have noticed is that the dupicate ID error upon upgrade always appears to be thrown by the RHP file of version 1.0.0, I can tell because the Plugin description has changed since then.
Im thinking the problem might be caused by the package setup we currently have?
Why does Rhino not clean up the registry after uninstalling packages via package manager?

I have looked at related posts to this subject, however I was unable to find a solution to my problem in those.

Hi @Georg,

Sorry for the late reply.

The issue is not the plug-in’s version number. But rather it’s GUID.

“ID already in use” means a plug-in with the specified GUID (found in AssemblyInfo.cs for C# projects) is already loaded. Plug-ins must have unique GUIDs.

– Dale

Hi @dale,
First of all, thanks so much for tuning in on the issue!
Unfortunately the issue persists after changing the GUID in AssembyInfo.CS.
What Ive realized is that the previous version of the Plugin is never removed/replaced by the new one in the registry.
The only way I have been able to get the new version to run is by changing the Solution name and therefore the rhp name, which of course creates just a new entry in the registry but it works for now as we are very much in a time crunch.
In the .csproj File there is a PackageID, but I wasnt able to figure out what exactly it does and where I can see which PackageID a Plugin has. I assume it is used to identify if different rhp’s are just versions of the same Plugin?
Thank you for your support!

This issue is still bugging me somehow.
There appears to be different behaviour when loading 1.1.0 directly compared to having 1.0.0 installed and upgrading to 1.1.0
When loading the new version directly, I can see the new command that has been added and the changes to the description instantly via the options->plugins tab, however when upgrading, there are two instances of the same plugin, both of them being the version 1.0.0.
I honestly cannot find a way this behaviour makes sense, but maybe I missed something obvious? Tried changing just about everything I could in the AssemblyInfo.CS and the csproj File and it’s properties. Even copied all new source code into the old project: Same result.