Don't want to show points when object is selected

Hope it’s a simple question. When I select a object, I don’t want control points to automatically show. I only want them to show if I press F10. It used to work this way, now it has suddenly changed to showing them every time I select an object. Can’t figure out what I did to make this happen. (Tried searching for this any answers are 7 years old and not applicable). thank you

Hi Robin - this is set in Options > Mouse page.

-Pascal

Thanks so much. It was making me crazy.