Docker Compute - Installing plugins


I am having trouble getting my plugin endpoints to display on compute docker instance. the docker image is built using compute.rhino3d:master
I have tried installing with registry, it registered
I have loaded/enabled using a python script. it returned as loaded but unable to see the endpoints.

See attached sample plugin and screenshot below.
p.s. seems like the new /grasshopper/solve endpoint is not there either. (35.7 KB)

Seems like compute services do not register the plugins added via registry.
I noticed that Rhino.exe needs to be executed to trigger the registration of plugins in the registry.
So I found two methods that worked, both of which requires executing Rhino.exe programmatically (run once):

  1. Add entry using Registry. Run Rhino.exe and exit programmatically. (otherwise this command will hang forever)
  2. Run Rhino.exe, install the plugin via command -_Options Plugins Load

This method worked with any .rhp that was unsuccessfully installed on docker instance using its original installers (i.e. ShapeDiver, because it had some UI components/popup/dialogs)
We didn’t test with the plugin installer method because the destination folder is dependent on the version of the plugin.
The goal is to have a custom folder location for our plugins, simple enough that we can replicate for debugging.
**compute.geometry.exe needs to be terminated before/after the execution of Rhino.exe in order for the newly installed plugins to take effect.