Cycles for Rhino

Cycles doesn’t handle reflections and transparency at the same time yet.
HDRI exposure is also ignored.

The 100% white fireflies are reduced with turning off caustics:

PS! And the meshing of revolved objects are a tad rough…

I just tried Cycles on a Windows 8.1 machine with a GeForce 9600 card and I got the same black screen as with the 330M, so can this be caused by an older CUDA version? Maybe your 420 is just new enough. I also see that the 420 had 96 cuda cores while the 330 has 64, could that be it?

Aren’t the display meshes being used?

This is the most likely explanation. With that few cores rendering on the CPU is also probably faster.

I use the render mesh iterator on the document, I am dependent on whatever it gives me. No further processing of geometry is done.

I think I know the problem already. I’ll check Monday when I am in the office. My other machine is now unreachable from home.

Correct, not yet implemented :slight_smile:

1 Like

Yes, it’s a v6 thing.

Reflectivity + transparency issue logged as RH-29654

Hmmm. I am constantly revolving things but can’t seem to have meshing problems. :confused:

Ok, I’ll look into it as it is a copy pasted V5 file, opened in V6, and it has some blocks.
And they ignore all render mesh settings.

I have a fix for this, and as soon I get a working SVN connection it shall be in :smile:


Nice! look forward to it!
The material editor icons are grayed out if I use Cycles, it calculates, but doesn’t update.
So I have to switch to Rhino render to get updates.

Also I did a test to see how the GI looks and I must say that Cycles is promising.
At ca 1300 cycles.

Here with two rectangular lights within a dark room (that casts shadows to eliminate the environent):

BUT if I delete a light then Cycles ignores it. It still calculates the light as if it wasn’t deleted. So I have to give them a black light to turn them off. (As it also ignores intensity)
Switching to and back from rhino render doesn’t clear that “cash” either.

Edit: Also it seems to ignore it if I disable shadow casting for objects.

Edit 2: As you can see the reflection of the rectangular light in the rear rim is very sharp, so it seems it doesn’t blur that propperly. The material is a gray paint with 4% glossyness.

Last Friday I had some help with a seemingly unrelated issue. With my own tests material previews are improved, although material conversion issues still exist.

Lights are on the list for revisiting.

Shadow cast toggling hasnt been added yet.

Glossiness isnt supported yet either. Simplest would be driving Roughness in the glossy BSDF, but wont be exactly same.

Thanks for testing and reporting!

Thanks for the feedback, and my pleasure :slight_smile:

In light of a wish posted on the ‘for Windows’ category I decided to check against rendering of a scene with a clipping plane. It seems like this is not supported at this point in time - all I get is a black image. As this is very early phase, I am fine with that but would like to set it rather high on the agenda nonetheless.

Neon came and went without ever supporting it. The RhinoRender seems to have partial support for the feature - the sections are not closed. Brazil supports it fine.

1 Like

I don’t know when I’ll be looking at this, but if it were up to me I’d get all render data properly clipped and capped from the render mesh iterator without ever having to worry about where clipping planes are. Not sure if @andy agrees with that, but I don’t know why a render engine ever should know about clipping planes…

edit Cycles doesn’t have a clipping planes itself.

Although it is a great solution to handle clipping planes early enough so it automatically works for all renderers, there are some arguments in favour of render engines handling it themselves:

  • Speed. It may be faster to handle planes in the ray intersector than to preprocess a lot of meshes.
  • Accuracy. It may be more reliable to handle clipping planes in the ray intersector than to preprocess a lot of meshes.
  • Functionality. It may be desirable for clipped geometry to not be visible, but cast shadows onto the visible part. Cutting open a building yet being able to see how the daylight works inside is an important feature for many arch. renderings.
  • Functionality 2 (this is a lame one). If the render engine supports making its own geometry (for example displacement maps), then a preprocessor cannot take that into account.

There may be other reasons as well, but I’m not a render expert and can’t think of any others.

Good points, so no clipping plane support until Cycles upstream supports them.

I disagree, a shadow clipping clippingplane is better than no clipping plane support :wink:

The material thumbnails are still blank on my laptop due to the lack of CUDA 2.0 support from the gpu.
Could you change this to CPU based rendering for the time being?

Also thanks for adding reflection to transparent materials.
And cudos for the ability to have both 100% transparency AND 100% reflection.

But as you can see the OpenGL and cycles need to be tuned a bit to appear more like each other.
And it seems like the high gloss reflections don’t have AA… Any idea what causes that?

Oh, and the bad meshing was due to custom mesh settings… My bad… :slight_smile: