Curvature Graph automatic in the "ArcBlend"


#1

When using the “ArcBlend” command, the curvature graph is automatically activated. There should be an option to enable and disable it.


(Pascal Golay) #2

Hi Davide - Are there cases where this is a problem, in real life? I can see that the scale could be wrong - it depends on the setting in the actual CurvatureGraph control, but apart from that, showing the graph while the points are adjusted - is that in the way somehow?

-Pascal


#3

Pascal, It is not a serious problem. But as for the “BlendCrv” command, where there is an option to enable or disable the curvature graph, the same should happen for the “ArcBlend” command: called coherence.
Nothing serious, anyway …


(Pascal Golay) #4

OK, yes, I understand that - the BlendCrv one can be much more obtrusive since it turns on the input objects’ graph as well and is on all the time - on ArcBlend the idea is maybe a little more limited - to help match the two arcs when adjusting the points. Unless this gets in the way somehow, I am inclined not to make the command more complicated…

thanks,

-Pascal