Creases within a loft

I am trying to create illustrations of a lot of plates. I have created profiles. The profiles have knuckles where the plates step down in thickness from top to bottom.

In the illustration, I have lofted the red profile curves. Then I did Divide Along Creases.

The purple lines show where the knuckles are.

However, there is no knuckle appearing in the surface at the top line. The angle at this particular knuckle is less than a degree.

Interestingly If I extract the top surface (that I want to be two surfaces), I cannot cap it back.

I am wondering how to accomplish this in volume.

Problem Loft.3dm (3.1 MB)

Dear bigjimslade
in _documentproperties -> Units you will find a angle tolerance which is set to 1 Degree by default - this is depending on the used template - in general it is a bad practice to change those settings during working on a file.
As the angle-Tolerance is set to 1 degree, an angle less then 1 degree is no crease / kink for rhino / your document anymore.
to fix your loft-surface:
_split (shrink = yes, Isocurve) the top surface - snaping to a “Knot” or the CV (Endpoint-Snap) of the red curves.
now rejoin the surface as needed.

just to give additional infos about creases:
There is another setting called _CreaseSplitting but it will not effect the result.
If you set _useExtrusions to No and extrude a rectangle you can see the effect of the creaseSplitting- setting - or check the help…

hope that helps

1 Like

I created a new file, set the angle tolerance to .1 (and .01 and .001), copied the contents over, lofted, divided along creases but I still did not get one at the top knuckle.

Hello- as far as I know this was tuned up in V6.