Can't split polysurfaces


I’m trying to prepare a model of Sydney for 3d-printing by adding a bottom to an otherwise flat model, but I can’t seem to get the split tool to work. I have created a box made out of polysurfaces that I’ve intersected with my model so that I can use the box to split the model to the right dimension, and also split the box using the model to create a solid bottom to the model.

I’ve tried converting both the model and box to meshes to try and use meshsplit, but to no avail. I’ve tried joining and exploding both polysurfaces and mesh but nothing seems to work. Please help, I’m going nuts trying to figure this out!


Hi -
When I open the model, I first see this:

89 bad objects were created while reading “C:[…]\sydney model.3dm”

Apart from that, when I select all but the box that you are trying to split the model with by clicking in one location, I get this:

173 points, 10346 curves, 1 surface, 7 polysurfaces, 9112 extrusions, 1 mesh added to selection.

When I then simply use Split to split the Sydney model with the box, it tries to split all of these points, curves, surfaces, polysurfaces, extrusions and meshes at the same time. Some of that won’t work because of the geometry type, some probably doesn’t work because of the bad objects (I didn’t wait long enough to find out - splitting seems to take a long time) - and - and this is important - the end result will still be one single group. So if you simply try to select a part that you expect to be split, it won’t select as a separate object.

I would advise you to ungroup the objects, get rid (or fix) the bad objects, and then only split the objects that clearly intersect with the box.