Can't get Region Union or Solid Union to work on these curves

This is the WIP build btw so perhaps it’s a bug that has been fixed.

EDIT Installed the Trial version and same problem there so doubt it’s fixed. Or perhaps I’m doing something wrong but I doubt it. I don’t see what I could be doing wrong in this case, there aren’t many options.

I can’t get Region Union or Solid Union to work no matter what I do. The command simply does not do what it’s supposed to.

I have two identical scenarios. In the top one I’ve got the curves connected to the sources by wires. The Bottom one I “baked” the sources and manually put em into these curve “containers”. Both Region Union commands have the exact same inputs one works the other one doesn’t.

Solid Union doesn’t work either, (just that they are Surfaces). Seems like a bug.

That’s often a faulty assumption. Try looking at it as if it’s not a bug, and more likely user error.

That doubt is very likely keeping you from the truth.

Posting a file is recommened.

1 Like

That’s not very helpful.

Well I figured out a way to get what I want anyway, but I have to use nearly 10x as many commands to achieve what the boolean union should do on it’s own.

I just have to split the 2 curves where they intersect and join the right pieces back together. At least those commands do what they are supposed to.

Btw boolean union and boolean difference works the way I would expect. If I was doing something wrong I don’t Think they would work either.

Perhaps I’ll upload a file later, don’t want to upload this mess of a Project. I’ll try and reproduce this result with something simpler.

We can’t help you without replicating the problem, which involves you sharing the file.
One thing which often confuses new users is that some components act on lists of data. For example the Region Union component takes all the curves in a list and tried to find the union shape containing all of them. However just plugging two curves into the input doesn’t necessarily put them in the same list. If one curve is stored under {0} and the other under {0;0}, what you will end up with two lists of one curve each. Region Union can do nothing with this setup, so it seems not to work.

But again, it’s all theorising until we can all use the same data.


Well I tried to recreate it in a new File, but this time it works. I noticed something is different, but I don’t know what it is.

Do you see the Picture? The instance where it fails is the panel with the bunch of zeros within the brackets at the top? There should be just one item in the list but apparently there is some other “junk” in there as well.

I don’t really want to share the file where it doesn’t work, it is it’s quite a mess, I don’t think anyone wants to look through it.

It’s probably something to do with what you said David Rutten. How do you fix this?. “List Item” command doesn’t change anything. There is still only one item you can get out of the list. Perhaps the items have different indexes even if there is only one item in each list.

One panel has {0,0,0,0,0} at the top, the other {0,0,0,0} (One less zero).

According to your screen grab, there is a problem with data tree matching with upper left case…
If the branch path level of the two data sets do not match, the region union will probably not work.
If so, you can use the Shift paths component to match the two data branch level.

1 Like

Thanks, that worked :slight_smile:

I hope you realize it wasn’t a bug at all. This kind of issue with data trees is very common, which is why posting a file helps to see the problem in context. You can make an abbreviated version of a complex file by internalizing the geometry immediately prior to where the problem shows up - and discarding everything after that. As explained in How to ask effective questions:


Thanks, that’s helpful to know.

Sorry to see this somewhat negative thread is not only dead, but that Google SEO is pushing it to the top for people investigating the problem.

Hopefully this saves someone some time. I am (in 2022) only able to get region union to work (and rather well at that) when I start with a primitive 2D shape. This can be a referenced in circle, or square or one drawn using grasshopper, doesn’t matter. I can perform whatever mutations I want, but it must start with a primitive. Limits the functionality somewhat but still super helpful!

1 Like

Hi -

What problem?

Buildings systems interacting with the Region Intersection / Region Region Union / Trim With Region commands. I found this when trying to work with existing sets of curves, both the fact that they were existing (created through the Bounding Rectangle function) and that they were a set of potentially hundreds of objects, led me here!

hahaha you are pretty much right. But @DavidRutten’s follow-up is pretty much the answer too – that the curves intended to be combined together just needs to be on the same list.

XX > “Flatten Tree” > Region Union

You could have saved yourself some time if you understood the replies that were posted.
Not a bug! It’s a misunderstanding of data trees.