Can't Download Windows 7 Evaluation

I’m trying to download the rhino7 evaluation. I use the link provided via email and I get re-directed to a window that says install. I click install and it pauses after a while a second window pops up which says

" (1)Error waiting for file C:\Program Files\Rhino 7\ System\Compat.exe. Verify that you have access to that directory. (1310) "

there are 2 options that say either retry or cancel. I’ve tried to retry and the same window just keeps opening Please Help

Are you downloading the eval version from here?

What OS are you on?

Yes I am. I have my email listed then got an email with a download link and code. I run the download link and I get that error message. (I don’t even get a chance to put in the code)

I’m running a windows based laptop

What version of Windows?

windows 10

OK, I am assuming your Windows 10 is up to date with all the latest service releases…

Do you get the same thing happening if you try to install the ‘full’ version?

yeah same issue. I’ve attached a photo below…

A recent thread with a similar problem. This one did not have any replies. Fail in installing Rhino7

1 Like

I’ve used Rhino 6 as a windows Evaluation prior and didn’t have any issues with it. My trial period ended though and I was trying to do another one. I would’ve tried to download rhino 6 again but it appears that it cant be downloaded because of the newest release of rhino 7

Thanks for making me here now^^

Hi Hel,
I got the exact same issue

Hi, I’m the original poster for this thread. I’m not quite sure how but I got it to work!

I’m going to tell you exactly what I did and hopefully this may work for you too.

Delete anything in downloads related to rhino 7 downloads
Go to and click the Rhino For Windows 7- Evaluation.
Enter a NEW Email
you will be sent a link and a new code.
click the link to download. Once downloaded it’ll ask to make changes to computer. accept.
IMPORTANT* When the rhino icon is on the screen click NEXT TO the install button. (This looks like a Settings button. Just verify everything and make sure its correct. It will also ask for a key. I put the license code there.
I restarted after this because still failed. But I did get an icon on my desktop.
Sign in with new account
enter license
Icon will be on desktop and it will run.
After I closed it though the icon was deleted
so I restarted and ran the download again. rhino will say its installed already. click the button that says repair.
It should fix itself and reinstall onto the desktop.
then it should be working fine.

I’m not sure if this will help and its very odd to try and do. Hopefully this will work for you. it worked for me

1 Like

I recommend you do not enter the key currently - there is a bug in the installer, if you enter a license key there you will get an error.

1 Like

I work in the other way.
Disable all the antivirus and firewall and then install.
Just don’t click that setting icon.
I asked a technician in McNeel and he said using that setting icon will have the bug.
The system will ask if u re using the rhino account or key to verify the license after.
So no worry for that

It works so well for me, super nice

1 Like