Cannot download Rhino 6 WIP? - (fixed)


(John Brock) #15

Try the link in @Ndawg’s post.
I just checked it and it’s working fine.


#16

Hi John,

do you mean this link: http://www.rhino3d.com/download/rhino/wip ?
Like explained, it does not work here (Germany) with Chrome, Edge or IE.

Jess


(John Brock) #17

@brian is the keeper of that system and he’s on holiday this week.
I don’t have a fix for this.
Perhaps @carlosperez or @stevebaer might have an idea.


#18

OK, no problem - I can wait until Brian is back.


(John Brock) #19

I’m going to bring up the problem in the Development meeting today to see if anyone else has any ideas, but I don’t have a lot of hope there will be a fix before Brian gets back. Even then, we have to understand the problem before we can fix it.
Sorry.


(Steve Baer) #20

I may be mistaken, but I believe the link only works if you go to it by starting from Bob’s welcome to serengeti post

http://discourse.mcneel.com/t/welcome-to-serengeti/9612


#21

Hi Steve,

Bob’s post / link was the first I’ve tried actually, but it does not make any difference.

Maybe it is a localization problem? Let me know if you need more info from my side.

Thanks, Jess


(Andrés Jacobo) #22

I’ve stepped in to try and fix the problem, and I believe I did.

It turns out it was a localization issue specific to German. German users should now be able to download the WIP from any major browser.

Please let me know if I am wrong.

Regards,
-AJ


(Thomas) #23

@aj1, did you change the encoding?

It seems, there is now a problem with the umlaut characters in the license email…

The download page works for me, though (FF, browser language is German)


#24

Thanks AJ, it works now.

And like Thomas mentioned already, the license email looks like this:

Betreff: Ihr Lizenzschl¸ssel f¸r Rhino WIP
Ihre Lizenz f¸r Rhino WIP:


(Andrés Jacobo) #25

@thomas, yes, that’s exactly what I did. I changed it to UTF8 since that appears to be the only encoding that rhino3d.com’s email system understands. Feel free to fix/replace the file with the properly encoded UTF8 text.


(Thomas) #26

Thank you @aj1!

Not sure why this wasn’t encoded in UTF-8 in the first place. I changed the umlaut characters…

Just being curious: how does the wrong encoding in this email message prevent the download page from loading?


(Andrés Jacobo) #27

I didn’t write this page, so I can’t tell you with authority why it is done this way, but before the page is displayed on the browser, the user has an email sent to them. Since the loading of that email crashes, the code that renders the page doesn’t run.


(Brian Gillespie) #28

When the download page tries to send the email, it has to read the localized email template and then send the message. When that fails, the rest of the download process dies with the error. This behavior is better than silently ignoring the encoding error, appearing to succeed, but failing to send the email. At least in this case we can see that there’s a problem, and then fix it.


#29

Brian,
I’ve just downloaded the latest version and I keep getting the following error:

Download Failed.
I’ve followed the steps outlined in the window but no success. What should I be doing differently?

Thanks.


(Brian Gillespie) #30

Make sure you delete the “redist” folder next to the installer before you start the download.


#31

I did and had the same result. I’m entering in the license number under the settings and I get a screen like it will begin to load and then the error screen appears. If I don’t enter in the license the app crashes.


(Brian Gillespie) #32

If you scroll down to the bottom of the Download Failed message, there should be a link to an error log. please send that log file to me.


#33

Hey Brian,
So I tried to install it this morning and it worked fine. I’m not sure what happened. I restarted several times yesterday after downloading thinking that might work.

I’ll post on the forum what happened if you’d like.

Thanks for your help.

Les Holland
Director of Engineering
Zepsa Architectural Woodwork
1501 Westinghouse Blvd.
Charlotte, NC 28273
704-583-9220 ph
704-583-9674 fx
les.holland@zepsa.com


#34

I have been getting the “Download Failed” error message for the last couple of releases, and I noticed in the error log the installer seemed to be failing to load files into the AppData/Local/Temp folder. So I went in and deleted everything in the Temp folder and then ran the installer again, and it worked this time.

Along the way I had to open Task Manager and close a couple of processes Rhino WIP had left running, otherwise I could not delete the linked files in the Temp folder. (Might a reboot have helped here?)

Just something others might try if they are getting this error message.