Building backwards compatible components / plugins


#1

Hi all,

Is it possible / feasable to build against older versions of rhinocommon? (Are they available for donwload somewhere).

I’ve got some plugins that I wish to build against older versions of the rhino service release - mainly because the requirements are quite simple. Is there another way than keeping older rhino installations available?

Regards, Arend


(Dale Fugier) #2

Hi Arend,

RhinoCommon plug-ins will only load in the same service release or greater of Rhino that the plug-in was build against. For example, if you RhinoCommon plug-in project references RhinoCommon.dll from Rhino 5 SR9, then your plug-in will load in Rhino 5 SR9, SR10, etc. But, it will not load in Rhino 5 SR8. Thus, if you want to support older service releases of Rhino 5, you will need to revert to an older service release.

Does this help?


#3

Hi Dale,

This partially answers my question - the followup question would be, are legacy rhinocommon builds available to compile against? If I wanted to build against for example the rhinocommon.dll from SR6 - apart from the possible compilation caused by me - are these legacy versions available (or are they still somewhere available on my hard drive, if I’ve got SR10 installed?).

Thank you for your time!


(Dale Fugier) #4

I don’t believe they are publicly available, with the reason being that we want users and developers to use the latest version, as it contains fixes and enhancements to both Rhino and RhinoCommon. But I’m happy to get you an older Rhino service release. Email me directly (dale@mcneel.com) and I’ll send you a link to download.


#5

Hi Dale,

so, if I get it right, starting with plugin-development after SR13 has been released, I cannot target users running SR12. Since SR13 does not trigger auto-update, we’d like to compile our tool to SR12 in order to reach as many users as possible.

I sent you an e-mail asking for a SR12-installer :slight_smile:

Best regards – Juergen