[BUG] Rhino 8 - Render Attributes - Invisible Object - Cast Shadows


While using the “Render Attributes” component, if the material’s “Cast Shadows” boolean flag is set to False the object reads transparent regardless of what material opacity settings are present.

This occurs in the Rendered view mode. In Arctic and some other view modes the object becomes completely invisible.

Shaded viewport remains unaffected of course.




If the boolean for Cast Shadows is set to True, the material performs as expected.

Graph Nodes:

Cast Shadows Set To True:

I realize that if objects don’t cast shadows or receive shadows then they would have no shading information in most rendering software and appear flat albedo/diffuse wise but the transparency here makes me think this is an unintended outcome?

@wim @AndyPayne not sure who works on the rendering side of things but wanted to bring it to your attention. Thank you both!

Thanks for bringing this to our attention. This does seem like a bug… but not from Grasshopper because I can repeat this even without using Grasshopper (just setting the cast shadows property to false on the object). I’ll make sure to file a YT item for this.

1 Like

Thanks Andy, much appreciated!

1 Like