Block Editing problem

I have a a problem when I try to create a closed polysurface from a mesh inside a block. The procedure I tried is:

  1. I entered to the Block Editing and I obtained a silhouette with section command to obtain a profile and an axis line to use revolve
  2. I used revolve command to create a closed polysurface
  3. I finished and I pressed Ok in Block editing window
  4. I have more geometries around the model
    block.3dm (215.3 KB)
    any suggestion to solve this?

This is what I expected to obtain.


Best regards

Jesus Lopez

Hi Jesus - I see this, I do not have a good explanation. When the object is blocked, it goes bad… Looks like a bug to me.
You can fix it inside BlockEdit by:
1.Explode the polysurface
2. RebuildEdges (defaults)
3. Join
4. Exit BlockEdit


Thanks for the reply. I tried differente options in Rhino6 and I found that if you rebuild an Arc or a Circle you don’t gonna have this issue. but this doesn’t work in Rhino5 :slight_smile:

Maybe really isa bug :slight_smile:


Jesus Lopez

@Punto_3D - The problem is that the block in your file has a transform that doesn’t work for block reference inserts in Rhino,
The bottom row of the transform is 0,0,0,0.1 and should always be 0,0,0,1

If you insert another instance of that block into the file the block edit that one, it will work right. If you insert it at scale 10, it will be the same size as the one in your file, but with a better transform.

Do you know how the file was made, especially, how the block insert was made?

@lowell Walmsley,

The original file was created in Sketchup. Usually I use that kind of files to simulate that is a file of a 3d model scanned and try to obtain silhouettes and sections to create the 3D model in Rhino


Jesus Lopez

@Punto_3D - Did you read a .skp file with Rhino then?

Can you send me a .skp file of that block so I can see what happens in the import?


@lowell Wakmsley

Of course, here is the original file Toy-Model-T-Delivery-Truck.skp (1.5 MB)

thanks in advance

Jesus Lopez

Thanks, That confirms the explanation above. I think we can correct for that in our Sketchup reader.

RH-54749 is fixed in the latest Service Release Candidate

1 Like