BlendSrf no longer works in newer versions

I’m trying to use BlendSrf to blend between two surfaces with the Rhino 5.0.2, something which worked in earlier versions, as per the following screenshot:

However, now when I try the same thing with the same exact geometry, Rhino just says “Can’t append that edge.” Has anybody else gotten this error? What does it mean if BlendSrf worked perfectly fine earlier?

I’d appreciate any help. Thank you!

Did you pick the input edges in a different location or change the geometry in any way? Can you post the 3dm file? I’m not sure what the append message means but can take a look at the file to help more. What version of Rhino for Mac are you using as well?

I didn’t change the geometry or the input edges in any way. Here is a 3dm file with different geometry than that pictured (I can’t share that), but it still has the same problem for me:

I’m using Rhino for Mac 5.0.2 as mentioned above. Thanks for the help!

You’re right, there is a problem with BlendSrf on Mac when compared to Windows Rhino v5 SR12. I’ll file this as a bug now, thanks ( In the meantime, here’s how I got it to work in Rhino for Mac. Use the Dir command on the outer surface and swap the U and V directions so they match the inner surface. This appears to be the issue.
TestFile_bjames.3dm (276.1 KB)

I don’t see the can’t append message and there’s no command history comment like this either. Can you send a screenshot of what you see?

That worked! Thanks!

Here’s the screenshot of the error:

Thank you so much for the quick reply and help!

I was also able to get it to work by using the Rebuild command on the outer surface before blending.