Add picture to scale 1x1

Hello,

I need to insert an image in all views scale 1x1

I have tried the following options

_BackgroundBitmap: I only insert the image into a single view, but I have the 1x1 option

_PictureFrame: I need to enter the length of the image, so if it is not 1x1 not scale, but is introduced in all views

Is there a command that allows me to make the 2 options?

Thanks

Having a 1x1 option for PictureFrame is on the “to-do” list for V6. For now, you can determine the size of the bitmap and then size the PictureFrame rectangle accordingly.

1 Like

Hi Manolo,

FWIW here is a python script for V5 that checks the DPI of the imagefile and scales the pictureframe accordingly.
PictureframeScale1To1_01_cmd.py (1.0 KB)

Please check the results, its presented “as Is”

HTH
-Willem

1 Like

Thanks for trhe script

Did this make it into version 6?

Hello - yep

image

-Pascal

Cool :sunglasses:

Thanks Pascal

There is not the option.

image

Hi Daniel - it depends upon the image having some resolution info - try this one -

-Pascal

Unfortunately no luck.

In V7 it works with your even mine.

Hi Daniel - can you please run _SystemInfo in Rhino and copy/paste the results here?

-Pascal

Rhino 8 SR7 2024-4-16 (Rhino 8, 8.7.24107.13001, Git hash:master @ aa01e3b9820d84a48c2a812d24f0cf42379ee3d8)
License type: Commercial, build 2024-04-16
License details: Cloud Zoo

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 32GB)
.NET 7.0.18

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 3070 (NVidia) Memory: 8GB, Driver date: 10-26-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 546.01
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-26-2023
Driver Version: 31.0.15.4601
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
C:\Users\danie\AppData\Roaming\McNeel\Rhinoceros\packages\8.0\NVIDIADenoiser\0.4.3\NVIDIADenoiser.Windows.rhp “NVIDIADenoiser.Windows” 0.4.3.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.7.24107.13001
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.7.24107.13001
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.7.24107.13001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.7.24107.13001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.7.24107.13001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.7.24107.13001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

it works for png, but the option is missing when you enter a jpg

1 Like

it seems more complicated than that. I have some that work and some that don’t.
RH-81665 No 1 to 1 option on some jpg files

after some searching i also found some jpg that work that are some from the web, but it seems that using photoshop to resave a jpg somehow breaks the option 1to1 for Rhino. i used different profiles, no profiles, different compression basis no matter what they do not work anymore. (i also saved as web)

using Mac Os Preview to resave as jpg that previously worked to a jpg again causes no issues, but it strangely does not heal a not working jpg, so a saved file from there seems to inherit the prior introduced problem.

png generally work no matter what, only

when images have apostrophes or other special letters in the naming they do not open at all also not as a png, it displays the selection prompt but the command stops after that without showing any further options.

here are 3 files, one that works, one with an apostrophe, and one that does not show the 1to1 option which virtually looks identical to the one that works.

Archiv.zip (532.7 KB)

1 Like

As you can read in the YT, this won’t and cannot be fixed. If the image contains no DPI info there is no sensible 1:1, and therefore that option won’t be available.