A problem with a simple fillet (Yes, I searched the forum for an answer! :) )


#1

OK, I searched the forum for the solution to this problem, but didn’t find (or didn’t understand) any possible solutions. I have an extrusion that I want to fillet. Please note that, if I select ALL of the edges, the fillet command works fine. But, I want to understand why the workflow I’m illustrating doesn’t work.

So, I select some edges to fillet:


Then, I select the edges at the end:

And, I get this:

Huh? What am I not understanding?

Thanks, in advance, for your help and suggestions.


#2

The second fillet is guaranteed to work as long as it is smaller than the first fillet. For aesthetic reasons,I usually make it half the size of the first. It’s one of those ‘golden rules,’ not to mention that most products typically don’t have same size fillets everywhere.


#3

If you did want the fillets all the same size, then fillet the short edges at the same time you’re filleting the long ones, not as separate operations. That usually works on simple geometry such as your example.


#4

I never knew that - that Rhino would put on the same size fillet if you select all of the edges at the same time. For years I’ve avoided using the same size, or built them manually. I wonder how complex the geometry has to be before it doesn’t work (it isn’t often that I’m working on simple straight extrusions)? I shall experiment.

Thanks for the tip, bjorf.


#5

FilletEdge will also allow you to place dis-similarly sized fillets at the same time as well. After picking your first set, before ending the command, just enter a new radius, and pick the edges for that radius. If you make a mistake, you can pick the handles you messed up on and change those. You can also use this to place variable radius fillets. One advantage of doing it all in one go like this is you don’t have to worry as much about working large to small.

Sam


(Pascal Golay) #6

However, sometimes it pays to work from large to small anyway - the results can be different and if the difference in radii is large, Rhino can make an ugly corner piece.

-Pascal


#7

Thanks to everyone for your comments and suggestions.

The fact that the process I illustrated works, provided the 2nd radius is smaller than the first, implies that this is a bug of some sort. Is that true, or is this “works as designed?”


#8

sort of buggy, sure.
you’re basically trying to put 1/8 spheres at the corners which rhino can do just fine as a revolve.

but i imagine there are some microscopic numbers which aren’t working out right when needing the singularities to occur in the fillet command . leading to the fail.
?

it could be an inherent problem of the computer itself /floating point math… or maybe within rhino itself
?


(Pascal Golay) #9

Hi Patrick - it is at least a ‘limitation’, it might be a bug that the same radius cannot be applied, but a smaller-than-edge-radius can’t work directly - the added fillet simply will not fit (imagine the rolling ball analogy- the new rolling ball can’t properly connect to the track of the one made by the previous, smaller one) so the shape has to be something other than a fillet there- Rhino does not know enough to restart the smaller fillet and run it up the intersection of the new one, if you see what I mean, and it gets more complicated if the edges are not straight, etc etc. So for the foreseeable future, large-to-small ids your friend, I would say…

-Pascal


#10

Woa…but why???

Vertical first, then horizontal

All at once


#11

Hi Dave

I use the same trick, but if I want all radii the same (or make them look the same), I reduce the radius by an extremely low amount and then I use FilletEdge again.

For practical manufacturing purposes, they will be the same and even a nice CMM machine will not be able to tell the difference.

Regards,

Costel



#12

Excellent tip! Especially if you DO need them to be visually the same – and don’t end up doing them at the same time.

Nice!


#13

Great suggestions and help! Thanks to everyong!


#14

A problem with a simple fillet (Yes, I searched the forum
In reference to Patrick Pirtle problem I have a plate 0.060" t x 2" x 5" that I have filleted the two long sides but can not fillet the short sides. We’re as the smaller plate filleted without a problem. Why?

I have tried ALL of the suggested remedies.


#15

Hey there! Post a handy and helpful pic. I have a very small brain.


#16

Hi Wyett

I followed my trick as posted above and that also worked with your plates. Made a small file as shown in picture.

Regards
Costel
Wyetts_Plates.3dm (556.8 KB)


#17

In my opinion this is a bug as equal is not the same as smaller than.


#18

I hope this is zipped
Wyett


#19

My be I should of filleted the plates before the cut outs.
Wyett


#20

I’m imagining it would be possible to solve this by adding a “RemoveFillets” command, which could work like this:

  1. Explode object
  2. Select and delete surfaces with degree of 2 in at least one direction (obviously this only works on non-variable, circular or elliptical fillets and probably selects some false positives in certain cases); this could work within a certain radius range.
  3. Untrim remaining surfaces
  4. CreateSolid from untrimmed surfaces

The user could then redo the fillets on this polysurface all at once.
The filletedges command could also identify when the fillet fails and offer to automatically attempt to remove fillets and redo them all in one go… I’m sure I’m missing a bunch of special cases etc :smiley:

I’m not sure if FilletEdge is history enabled, but that could be another way to solve this.

Cheers,
Steven