5 degree surface display issue

As I am playing with 5 degree ship hull surfaces, I noticed strange behavior of both Rhino 5 and 6.
I found out that advanced display settings of my 5-Degree surface isn’t used for display.

  1. In the attached file, you can find the original Nurbs surface with advanced display quality settings showing poor in glossy display

  2. ExtractRenderMesh shows a rough mesh with poor display quality that seems to be used for the actual display of the Nurbs surface

  3. A Mesh extracted from the Nurbs object with the same settings as the advanced render mesh settings, does show smooth.

5DegreeDisplayQuality.3dm (4.8 MB)

Bad display of Nurbs object with advanced display settings:


Nice display of mesh:

Try setting the display to “Flat Shade” so you can see the render mesh facets without the fake smoothing.

Hi Gerard - I see this… still digging…
It seems that if I actually shade the viewport and then ExtractrenderMesh, I get the right mesh - is that what you see? If I ExtractRenderMesh without ever shading a view, then I get the wrong mesh…

-Pascal

Thank you John and Pascal, for your replay.

Thanks for reminding me about the flat shade functionality. That is useful to examine the render mesh.

This morning, I opened the newsgroup example file and the render mesh showed well. However, the original file still showed the rough mesh instead of the refined mesh, I set with the per object advanced mesh settings.
But after editing a control point position with a large step, it flipped to the smooth settings.
So there seems to be something not working perfectly, but at least I know how to solve it with the work around of moving a control point.