3d printing dimensions

I am trying to get into using rhino for 3d printing. But i’m having trouble with scaling. I tried starting with a simple 1x1x1 cube, and it comes out of the printer insanely tiny with just 9 printable layers. I tried setting the template in millimeters, inches and even feet, but no matter what, the export always come out the same.
How do I set up the build so that 1 square in rhino equals to 1 square inch of printable surface?

Of course STL files are super-dumb and don’t contain units, so you may have to scale them in your slicer, or it should have an option to assume what the units are. Rhino exports STL in whatever the file units are.

So what ? Everyone knows that the STL format is dedicated to 3D printing

I’m creating STL file for 3D printing from Rhino since 2005 and never had this issue.
The problem could be the slicer.
What slicer do you use?
Did you check the import options?

I am using FlashPrint. My guess the error occurs during the export/import transfer, Since all dimensions come out the same, no matter if feet or inches. More likely its the export from rhino. It exports a 1x1x1 inch cube at 1kb file size, which should simply be larger than that.

Hi Leo -

As was already said, the STL file format doesn’t state the units in the file. You’ll have to set that in the receiving application somehow.

Why is that?
You can export in the ascii format and open the file in Notepad to see the contents.

I am confused, if STL does not contain dimensions, how is it possible to create accurate dimensions without units? Also other models that I print (downloaded), come out fine without any adjustments.

Hi -

I didn’t say that.
The STL file contains dimension. It doesn’t contain units.

I don’t know FlashPrint… Perhaps it assumes that STL files are in millimeters?

I assume those are Rhino templates? Are you exporting a 25.4 x 25.4 x 25.4 cube in the millimeters template or a 1 x 1 x 1 cube?

those are rhino templates, yes. I literally just made a solid 1x1x1 cube and hit export selected. I can scale it up in flashprint to be a 1 inch cube, which is fine for simple shapes, but if you’re building something more complex, precision is needed.


… depends on how you define insane, but, yes, it sounds like FlashPrint assumes millimeters.

Hi Leo,

FlashPrint expects object units to be millimetres. So use a millimetre template and draw a cube 25.4 x 25.4 x 25.4 and that will load into FlashPrint as a 1" cube. If you load it and open the scaling tool you should see the correct size (and you can swap to inch display).




The stl contains dimensions - as simple numbers without UNITS. So a 1x1x1 cube can be interpreted as:

one inch by one inch by one inch
one foot by one foot by one foot
one millimeter by one millimeter by one millimeter
one meter by one meter by one meter
one light year by one light year by one light year

As machines work mostly in inches or mm, it’s usually one of those two.

Looks like your 1 inch cube is being interpreted as a one millimeter cube.

My work around is to use a document with a dinension setting (mm in normal case) and then create a mesh in rhino (to have total control while generating and export it as a .3mf for printing.
3mf is kind of a better stl because of the dinension settings and more meta data. But most os (like macOS does not preview the files at the moment).
I create the mesh before because while export as a 3mf there is no mesh dialogue like the obe from the stl. (maybe good point for the future). Rhino uses the document mesh settings here.

Ok, that makes sense now, thank you very much.

1 Like