Zoom now not possible on Magic Mouse after update


#1

A really annoying problem has occurred since updating to version 2014-01-29 when zooming in and out of a model. I now have to press command and then scroll on the magic mouse whereas before I could just scroll and it would zoom. This really becomes a problem when wanting to scroll and pan (right click) as it sometimes continues to zoom. Its making using Rhino a lot slower. Anybody got any advice how to get round this?


(Brian James) #2

Hi Josh,

I’m not seeing this issue here using OSX 10.9.1. What OSX are you running?


#3

I’m running 10.9.1, its very annoying I have to press command to zoom in whereas previously I could just scroll normally as if in safari etc to zoom into the model.

Thanks


(Brian James) #4

It sounds like you’re trying to scroll with the gesture of dragging one finger over the center of the mouse which is controlled by this setting in ⌘, > Mouse >Magic Mouse


I can repro the need to hold down ⌘ if this is off and I’m using the secondary/right click.

Is this gesture option checked? If so, does this scroll gesture work elsewhere in OSX like you mentioned?


#5

Its working OK now. I had previously checked ‘Enable Magic Mouse gestures’ but still had to press command.

Cheers for your help!

Josh