Zoom Extents Off-Centered w/ linked block


#1

Hi,

Don’t know what is causing this, but I have a file where zooming extents in Layout space pushes the actual extents over to the left, off of screen-center. It seems to be the linked file title block I am using.

When trying to de-bug, I completely deleted all the title blocks, purged the link from Block Manager and tried again. OK, zoom extents properly centered the Layout on my computer screen. Re-inserting the block, then trying zoom extents again pushed the extents back off of screen-center.

Yet on a brand new file, I made a one-detail Layout (toolbar click), and pasted the linked title block in. Zoom extents worked fine in this file.

Files are attached if someone can figure out what goofiness is going on.

Thank you,
Matt

york_extents-asymmetry.3dm (112.1 KB)
york_extents-centered.3dm (37.0 KB)
york_title02.3dm (46.9 KB)


(Pascal Golay) #2

Hi Matt- it’s the text that is causing it but I don’t know why yet. If you look at the preview in BlockManager all the text york_title is oversized and off to the right. I tried messing with the text scaling in the Title file but it did not help so far.

-Pascal


#3

Hi Pascal,

Thanks for finding that out. It led to the culprit but I don’t know what should be done to solve it.

The main file has the Options/ Annotation Scaling set to 16. If that is changed back to 1, then the title block will look correct in the BlockManager. The file in Layout space will also properly zoom to center upon zoom extents. However, then any dims, text, etc, inside the main file’s model space cannot be read at anything other than an Annotation Scaling = 1 (kind of defeats the purpose of the scalar, doesn’t it?).

I looked at the title block file too. It actually had Annotation Scaling OFF. Even when I turned it ON to 1, resaved the file, and reloaded it into the main file, kept at Annotation Scaling =16, it did not solve the problem.

Should the title block be made inside its file in Layout space, not Model space? I did not try this because I did not think you could block/link it in that way.

Thanks,
Matt


(Pascal Golay) #4

Hi Matt- I think this is just a bug, I don’t know what a workaround might be yet, I’m afraid. In any case, I’ll buggify it and see what the developer has to suggest.

-Pascal


(Declan Halpin) #5

Hi,

I am actually seeing the same behavior on my machine without blocks. File attached, although it happens with all files, not just this one

ZoomExtentsQSTN.3dm (151.0 KB)

dh


(Declan Halpin) #6

Is there a setting anywhere that adds a margin to ZoomExtents? That’s what this behaviour feels like.


#7

SetZoomExtentsBorder