Zoo License Management Discussions

Discuss the Zoo, or configuring Rhino to use the Zoo.

Can I check who is currently using which license? By i.e. computer name?

Yes. Just open the Zoo Admin console, and you’ll see who has licenses in use by user and computer name.

Alternatively you could just use the server´s status page, as described in “Managing Licenses”:

Remote License Monitoring
The Zoo allows administrators and users to monitor license usage from the convenience of their web browser. Just visit the “status” page provide by your Zoo server by entering:
into your favorite web browser. For example, if your Zoo server’s host name is zooserver.mycorp.com, then you’d enter:

A Zoo 6 managed Rhino 5 license was checked out, later the PC died (losing the CHK file in the process). Is there a way to recover a checked out license in Zoo 6 before it expires and the zoo automatically recovers it?

@dale can you please help?

From the Zoo Administrator, select the license that is checked out and then pick Edit → Recover.

Does this help?

– Dale

Thanks Dale. Yes that did it. It’s self evident isn’t it? Next time I’ll explore Zoo commands a bit more before exploring Zoo wiki and Google searches!

Or just ask here. :wink:

– Dale

We changed our License Server Computer (from a virtual machine to a real one).
The new computer has a new ip address, which can – of course – be altered on our ferw client computers.

  1. Now at every start of Rhino for Mac I get the “missing license dialogue” (with the wrong (old machine´s) IP in the settings when I look there).
  2. I can enter the correct IP address, which gets accepted.
  3. Rhino gets a license from the server

But next day everything begins from step 1.

How can I be sure the settings for the license server´s IP address don´t get lost?

Suggestion: Probably the user has to have admin rights … — NOT the solution.

Rhino for Mac v. 5.3.2

Version 6 SR0
(6.0.15149.9391, 29.05.2015)

Hi @msmr,

The Rhino for Mac installer runs chmod with +rwx on the license file so anyone can write information to it. If you delete the license file manually, you’ll need to re-chmod it.

– Dale

Actually, I didn’t delete it, but edit the license (IP), so I wasn’t sure what happens in the background.

Good to know that now!


Where do I find the license file, actually?

I was looking here …

… but the folder is empty.

Or, do you mean on the server?

Ahhh, I got it.
(Not in the personal library under /users/, but in the main library:

Macintosh HD/Library/ …


btw., the dialogue window when starting to edit the license looks like this on my machine:


I cannot access any features (except Event Viewer and Usage Tracking) in the Zoo 6 Administrator as they are all greyed out in menus/icons.
It’s a new installation on Windows 10 Pro.
I have reinstalled several times with no luck.

Any help appreciated!


Hi @Ricard,

if all the control are grayed out, then the Zoo service isn’t started. Poke the arrow button on the toolbar to start the service.

– Dale

Hi Dale,

Thanks for your response!

I did poke the arrow from the start but the Zoo manager becomes non responsive and subsequently I have to force quit.

When using the Zoo manager on another computer (also Windows 10 Pro) there is no problems. I can add a license and then start the service.

Is there any security settings in Windows 10 that can cause the problem?
(I run the Zoo manager as administrator.)

Thanks again.

Problem solved!

I had some problems with security updates that couldn’t be installed so I had to reinstall Windows.
After that Zoo worked as it should.


Great! Thanks for the update.

– D

A post was split to a new topic: CloudZoo issue