Zoo 5.0: Failed to lookup local host name

Zoo 5.0 SR8 worked perfectly on my Windows 7 Pro 64bit PC, until yesterday, when I cloned my system drive from a HDD to SSD using the Samsung Data Migration tool.

When starting the system the Zoo service doesn’t start automatically anmore. When examining Windows’ event log (German: “Ereignisanzeige” ) I find an Error “Failed to lookup local host name”.

I’ve waited more than 5 minutes before logging on, but the service didn’t start. When starting it manually from the Windows Services, it starts normally with saying “Zoo Server Hostname: mycomputer” in the Event Log.

My questions are now

  • what can be gone wrong while cloning the hard disc that causes this error now?
  • what can I do help the Zoo service to get the local host name and to start automatically again?

Any hints are very appreciated!

Self reply: I downloaded and installed the latest Zoo version 6.0. Same result: Failed to lookup local host name. The service doesn’t start automatically anymore. Manual start after log on working without problems.

What the … is going wrong here? :rage:

The event log / Windows Protocol / Applications lists the following error:

Der Dienst kann nicht gestartet werden. System.Exception: Unable to start Zoo Service
** bei ZooService.ZooService.OnStart(String[] args)**
** bei System.ServiceProcess.ServiceBase.ServiceQueuedMainCallback(Object state)**

Any ideas anybody?

Self reply: Nobody has any idea?

What I’ve done so far:

  1. Shut down the PC, cloned the HDD -> SSD once more, this time using AOMEI Backuper
  2. Unplugged the HDD, booted again from the SSD, (with the “old” Zoo 5.0 again), same error: Zoo service wasn’t started at boot time due to “Failed to lookup local host name”
  3. Shut down the PC, unplugged the SSD, plugged the original HDD, booted the PC
  4. Zoo service running without any problems.

Please, has anybody any idea what can go wrong if I boot the identical system from a SSD? Is one of the drivers doing anything wrong? Is the system booting too fast (hey, that can’t be true)?

If you get to a Windows command prompt and run “hostname”, what is reported?

If I call hostname I get the host’s name (hgdrn7). That’s not the point. The Zoo service starts normally if I start it when logged on. The problem appears at boot time, and I don’t know what the hostname command responds when it is called during the boot time when the Zoo service is started.

I’ve currently fixed the problem using a “Automatic (Delayed Start)” as the Default Start Mode for the Zoo service. The “funny” situation is now that (using the SSD) my system is botting three times faster than before, but I have to wait about 2 minutes before I can use Rhino, because Windows is starting the service with these 2 minutes delay. :confused:

07:22:20 - System started
07:22:36 - McNeel Update Service started
07:24:49 - Zoo 5.0 service started

If I use start method “Automatic” Windows reports the upper error “Failed to look up host name”.

So, I have a solution with the Delayed Start for my folks here. They switch on my computer and will be able to use Rhino some minutes later. I’ll try now to set up a Virtual Machine with Win7 and Zoo on a 24/7 Linux Server as a better solution.

But I’m still interested what’s going wrong here. :wink: