Z axis color


#1

Just a little thing, but unable to set the color of the z axis. It always takes on the color of the y axis. The default colors are accurate but as soon as I change them the z axis is the color of the y axis.


(Scott Davidson) #2

I am using the most current build. I can change the X,Y and Z axis independent of each other. And it holds in the display. I suspect I have not stumbled upon the exact steps to re-create the problem.

Can you help answer a few questions:

  1. What display mode are you currently running in?
  2. Which viewport are you testing the Zaxis color in?
  3. When you change the Z-color, do you also change another axis color?
  4. Are you turning on the Z-axis in the grid settings?

Perhaps I can re-create the problem here?


#3

Here is a snap. https://dl.dropboxusercontent.com/u/5048027/zaxis.png

  1. Wireframe, rendered also
  2. front and side
  3. does not change anything
  4. Yep it is on in the document settings

#4

that’s right. those are the x&y axis of the front and side view cplanes.

(for instance, if you draw a line vertical in those viewports, it’s going to come straight at you and you won’t be able to see a z height on it.)


#5

It would help me distinguish the front view from the top view if the z axis were blue in the front and side view and have just one xy plane and not 3. I guess you could say that each view has a separate xy plane but I usually don’t.


(Scott Davidson) #6

Each view does have its own Cplane. This is something Rhino has always done. What you see in the view is the local cplane. In the Front and Side views, the Z axis is point directly at you.


#7

you can try File-> Settings-> Grid-> ‘Show world axis icon’

it will show the z axis in the way you’re asking… not as obvious as a blue line running across the viewport but…


#8

Has this item been resolved?
I have the latest version (2014-6-10) and am using OSX 10.9.3.
Boot Rhino, select a template (small objects - feet). Three viewports open. X axis is red, Y axis is green and Z axis is green.
Go to preferences.
Change the Z axis to purple. Changes in the preferences but not in any viewport.
Change Y axis to blue. Y axis changes to blue in viewports perspective and top, but Z axis also changes to blue in viewports front and right.
Thanks,
Peter


#9

Nope. Z axis is unchangable.

Sincerely,

Steven Houtzager
Intuition = Immediate Understanding
voice 404 219 2193
[ intuitionusa.com ]