Yak yank case-sensitive

Hi @will

I’ve tried to push a package that I wanted to revoke:

.\yak yank scriptparasite 1.1.2
Successfully yanked scriptparasite (1.1.2)

Yak search seems to agree: (could only find 1.1.1)

.\yak search scriptparasite 
ScriptParasite (1.1.1)

However: this package is still shown in the package manager.

Only after I’ve tried (note the case)

.\yak yank ScriptParasite 1.1.2
Successfully yanked ScriptParasite (1.1.2)

The package also disappeared from the package manger…

I would expect
a) yak yank to fail
b) that the package be removed from rhino

But not Schrodinger’s yank: where a package is both removed and not removed at the same time.

1 Like

Thanks for reporting this @arendvw. I looked into it and I found a case-sensitivity bug in the server-side response caching. The database is correct but the cache wasn’t invalidated so you got a stale response. I’ll fix this ASAP.

1 Like

As a side note: from usability kind of view it would be nice to not be able to successfully yank a package twice: so there’s no confusion about if a package has been yanked.

All fixed.

To keep things simple I don’t check first to see if the version has already been yanked or unyanked. I’ll add the request to the list.

I generally use the command below to confirm which versions are listed.

yak search --all --prerelease <name>

1 Like