Wrong language

When starting up Rhino 7 WIP wrong system language is chosen.
I have both Swedish and Polish, Swedish primary. Rhino starts in Polish.

Rhinoceros pull-down > Preferences > Language
Choose what you want, Quit, and reopen.
By default, Rhino chooses the language your MacOS is in.
That’s generally a pretty good guess.